aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2018-08-06 17:45:07 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-08 12:04:14 -0700
commit69a76839863c2eb6e2840367f04096be9e57fed2 (patch)
tree211aad9d150497a3db298f014afd131844b460b2
parentfd87dc89e18406d42555e978cae319107bcd2cac (diff)
downloadmeta-python2-69a76839863c2eb6e2840367f04096be9e57fed2.tar.gz
python-future: make recipe available as python3 version
(From meta-openembedded commit: aee991551f113fa8b65b67155d4d36e6ccd2e3f5) Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-future.inc13
-rw-r--r--recipes-devtools/python/python-future_0.16.0.bb15
2 files changed, 15 insertions, 13 deletions
diff --git a/recipes-devtools/python/python-future.inc b/recipes-devtools/python/python-future.inc
new file mode 100644
index 0000000..2247561
--- /dev/null
+++ b/recipes-devtools/python/python-future.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Clean single-source support for Python 3 and 2"
+HOMEPAGE = "https://python-future.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3f457538b297bd0ef86564b8ac216ad7"
+
+SRC_URI[md5sum] = "3e8e88a2bda48d54b1da7634d04760d7"
+SRC_URI[sha256sum] = "e39ced1ab767b5936646cedba8bcce582398233d6a627067d4c6a454c90cfedb"
+
+PYPI_PACKAGE_HASH = "99abde815842bc6e97d5a7806ad51236630da14ca2f3b1fce94c0bb94d3d"
+
+inherit pypi
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-future_0.16.0.bb b/recipes-devtools/python/python-future_0.16.0.bb
index 46f7fe5..d95e1ba 100644
--- a/recipes-devtools/python/python-future_0.16.0.bb
+++ b/recipes-devtools/python/python-future_0.16.0.bb
@@ -1,13 +1,2 @@
-DESCRIPTION = "Clean single-source support for Python 3 and 2"
-HOMEPAGE = "https://python-future.org"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3f457538b297bd0ef86564b8ac216ad7"
-
-SRC_URI[md5sum] = "3e8e88a2bda48d54b1da7634d04760d7"
-SRC_URI[sha256sum] = "e39ced1ab767b5936646cedba8bcce582398233d6a627067d4c6a454c90cfedb"
-
-PYPI_PACKAGE_HASH = "99abde815842bc6e97d5a7806ad51236630da14ca2f3b1fce94c0bb94d3d"
-
-inherit pypi setuptools
-
-BBCLASSEXTEND = "native"
+inherit setuptools
+require python-future.inc