aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDwane Pottratz <dwane.pottratz@intel.com>2018-10-05 10:33:43 -0700
committerKhem Raj <raj.khem@gmail.com>2018-10-05 14:51:14 -0700
commit52f153971ca0d592195677991a404eabefe57f36 (patch)
tree07ceffe1e2967f1e50ff6f685101516badbd7b18
parent7549f13d718398648c778da4784664f79b24aa03 (diff)
downloadmeta-python2-52f153971ca0d592195677991a404eabefe57f36.tar.gz
python-sh: add python sh library
sh is a python subprocess replacement. (From meta-openembedded commit: 99ecc889a0909d54b6bb5c795087585adde1bfbd) Signed-off-by: Dwane Pottratz <dwane.pottratz@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-sh.inc32
-rw-r--r--recipes-devtools/python/python-sh_1.12.14.bb8
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-sh.inc b/recipes-devtools/python/python-sh.inc
new file mode 100644
index 0000000..f2fd562
--- /dev/null
+++ b/recipes-devtools/python/python-sh.inc
@@ -0,0 +1,32 @@
+SUMMARY = "Python subprocess replacement"
+HOMEPAGE = "https://github.com/amoffat/sh"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5317094292296f03405f59ae5f6544b6"
+
+SRC_URI[md5sum] = "a8351aef25d25f707c17e0a7a6280251"
+SRC_URI[sha256sum] = "b52bf5833ed01c7b5c5fb73a7f71b3d98d48e9b9b8764236237bdc7ecae850fc"
+
+PYPI_PACKAGE = "sh"
+
+inherit pypi
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-resource \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-tests \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-unixadmin \
+"
+
+# WARNING: We were unable to map the following python package/module
+# dependencies to the bitbake packages which include them:
+# coverage - only used in test and there is a check to see if it is
+# available before importing.
+# queue - part of threading
+# signal - part of core in python3. not sure how it is imported in python2.
+# No complants in compiling.
diff --git a/recipes-devtools/python/python-sh_1.12.14.bb b/recipes-devtools/python/python-sh_1.12.14.bb
new file mode 100644
index 0000000..7cb5140
--- /dev/null
+++ b/recipes-devtools/python/python-sh_1.12.14.bb
@@ -0,0 +1,8 @@
+require python-sh.inc
+inherit setuptools
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-contextlib \
+ ${PYTHON_PN}-lang \
+ ${PYTHON_PN}-textutils \
+"