aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2018-08-02 20:27:04 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-03 09:34:29 -0700
commit2fb7d2b05342c88cc28a419949d115d51988e98e (patch)
tree40aaf89905a48489cf7a31781aa0d3b7caac8711
parent047f27ea0098dbc334e7a6d81ccc496c090b4910 (diff)
downloadmeta-python2-2fb7d2b05342c88cc28a419949d115d51988e98e.tar.gz
python-behave: Add Python 3 recipe
Fix broken dependencies of Python 2 recipe as well. (From meta-openembedded commit: 240b92343ea836b408bc5a0d9678bffa36d7a819) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-behave.inc15
-rw-r--r--recipes-devtools/python/python-behave_1.2.6.bb16
2 files changed, 22 insertions, 9 deletions
diff --git a/recipes-devtools/python/python-behave.inc b/recipes-devtools/python/python-behave.inc
new file mode 100644
index 0000000..ded7580
--- /dev/null
+++ b/recipes-devtools/python/python-behave.inc
@@ -0,0 +1,15 @@
+SUMMARY = "A behavior-driven development framework, Python style"
+HOMEPAGE = "https://github.com/behave/behave"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d950439e8ea6ed233e4288f5e1a49c06"
+
+SRC_URI[md5sum] = "3f05c859a1c45f5ed33e925817ad887d"
+SRC_URI[sha256sum] = "b9662327aa53294c1351b0a9c369093ccec1d21026f050c3bd9b3e5cccf81a86"
+
+inherit pypi
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-parse-type \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-six \
+ "
diff --git a/recipes-devtools/python/python-behave_1.2.6.bb b/recipes-devtools/python/python-behave_1.2.6.bb
index 6797302..6622168 100644
--- a/recipes-devtools/python/python-behave_1.2.6.bb
+++ b/recipes-devtools/python/python-behave_1.2.6.bb
@@ -1,10 +1,8 @@
-SUMMARY = "A behavior-driven development framework, Python style"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d950439e8ea6ed233e4288f5e1a49c06"
+inherit setuptools
+require python-behave.inc
-SRC_URI[md5sum] = "3f05c859a1c45f5ed33e925817ad887d"
-SRC_URI[sha256sum] = "b9662327aa53294c1351b0a9c369093ccec1d21026f050c3bd9b3e5cccf81a86"
-
-RDEPENDS_${PN} += "python-difflib python-setuptools python-pkgutil python-misc python-argparse python-xml python-enum34 python-parse python-parse-type python-six"
-
-inherit pypi setuptools
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-argparse \
+ ${PYTHON_PN}-enum34 \
+ ${PYTHON_PN}-traceback2 \
+ "