aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSipke Vriend <sipke.vriend@gmail.com>2018-05-10 09:12:24 +1000
committerArmin Kuster <akuster808@gmail.com>2018-06-14 19:58:51 -0700
commitb832f0934dc64ad39a84530eb4a378a62492210d (patch)
treed9209b182954bc0ac369213524044cb268507843
parent706aa43a6926c69a5f9fa27fe88ecab7e11e49e4 (diff)
downloadmeta-python2-b832f0934dc64ad39a84530eb4a378a62492210d.tar.gz
python-robotframework: Add runtime dependencies to robot framework
Add the runtime dependencies robot framework has so they are available on images including it. python-robotframework.inc is included by both python3 and python robot framework. python3 includes zlib by default so include python-zlib as a runtime dependency in the python-robotframework recipe and not in the python3-robotframework. (From meta-openembedded commit: 734513d8b31cd68da01db1cf880788c190ae6457) Signed-off-by: Sipke Vriend <sipke.vriend@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> (cherry picked from commit f90318b625a90993c4e20c981201602e37f89481) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-robotframework.inc11
-rw-r--r--recipes-devtools/python/python-robotframework_3.0.2.bb4
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-robotframework.inc b/recipes-devtools/python/python-robotframework.inc
index cc20d64..78bbbc6 100644
--- a/recipes-devtools/python/python-robotframework.inc
+++ b/recipes-devtools/python/python-robotframework.inc
@@ -13,3 +13,14 @@ inherit pypi
SRC_URI[md5sum] = "ea49a54b9d7e38302712194e85c37eaa"
SRC_URI[sha256sum] = "2018f233568227f9af8c366f93e243a157b742f3baf5b649ecc9750ac0ee1ff7"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-docutils \
+ ${PYTHON_PN}-ctypes \
+"
diff --git a/recipes-devtools/python/python-robotframework_3.0.2.bb b/recipes-devtools/python/python-robotframework_3.0.2.bb
index 16eaa78..ff7dedb 100644
--- a/recipes-devtools/python/python-robotframework_3.0.2.bb
+++ b/recipes-devtools/python/python-robotframework_3.0.2.bb
@@ -1,2 +1,6 @@
inherit setuptools
require python-robotframework.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-zlib \
+"