aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-03-22 09:11:52 +0000
committerArmin Kuster <akuster808@gmail.com>2018-04-08 17:00:06 -0700
commit7d6343d814a32b0399e73ad31329ecce92ecca33 (patch)
tree4900e51f62998ddfde08b73b1917d946a0f5e13a
parentd48008d8c983749072b21023a6396e38f0332364 (diff)
downloadmeta-python2-7d6343d814a32b0399e73ad31329ecce92ecca33.tar.gz
python-aws-iot-device-sdk-python: also package examples (as additional package)
(From meta-openembedded commit: bd44421f579269f2b37cab8149beb7ae844eb92d) Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-aws-iot-device-sdk-python.inc13
-rw-r--r--recipes-devtools/python/python-aws-iot-device-sdk-python_1.3.1.bb2
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-aws-iot-device-sdk-python.inc b/recipes-devtools/python/python-aws-iot-device-sdk-python.inc
index 7b60660..a3299e4 100644
--- a/recipes-devtools/python/python-aws-iot-device-sdk-python.inc
+++ b/recipes-devtools/python/python-aws-iot-device-sdk-python.inc
@@ -1,6 +1,7 @@
DESCRIPTION = "SDK for connecting to AWS IoT using Python."
HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-python"
LICENSE = "Apache-2.0 & (EPL-1.0 | EDL-1.0)"
+LICENSE_${PN}-examples = "Apache-2.0"
LIC_FILES_CHKSUM = "\
file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \
file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \
@@ -13,6 +14,15 @@ inherit pypi
PYPI_PACKAGE = "AWSIoTPythonSDK"
+do_install_append() {
+ install -d -m0755 ${D}${datadir}/${BPN}/examples
+ cp --preserve=mode,timestamps -R ${S}/samples/* ${D}${datadir}/${BPN}/examples
+ # this requires the full blown AWS Python SDK
+ rm -r ${D}${datadir}/${BPN}/examples/basicPubSub
+}
+
+PACKAGES =+ "${PN}-examples"
+
RDEPENDS_${PN} += " \
${PYTHON_PN}-crypt \
${PYTHON_PN}-datetime \
@@ -24,5 +34,8 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-numbers \
${PYTHON_PN}-threading \
"
+RDEPENDS_${PN}-examples += "${PN}"
+
+FILES_${PN}-examples = "${datadir}/${BPN}/examples"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/python/python-aws-iot-device-sdk-python_1.3.1.bb b/recipes-devtools/python/python-aws-iot-device-sdk-python_1.3.1.bb
index 12ae978..490e973 100644
--- a/recipes-devtools/python/python-aws-iot-device-sdk-python_1.3.1.bb
+++ b/recipes-devtools/python/python-aws-iot-device-sdk-python_1.3.1.bb
@@ -1,2 +1,4 @@
inherit setuptools
require python-aws-iot-device-sdk-python.inc
+
+RDEPENDS_${PN}-examples += "${PYTHON_PN}-argparse"