aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-04-02 11:03:43 -0400
committerArmin Kuster <akuster808@gmail.com>2018-04-08 17:00:06 -0700
commit6a5f34364ca1c7c7eb0efe20b06d1b09364466b4 (patch)
treef945a6b9430c0c9ddc34d70a441361ec110d6a32
parent9516a1bd34c0947b9b52b42ba8844470068f59fd (diff)
downloadmeta-python2-6a5f34364ca1c7c7eb0efe20b06d1b09364466b4.tar.gz
python-jsonpatch: fix do_install failure with py2 build
The following error is seen when do_install is run | UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in | position 16: ordinal not in range(128) ERROR: python setup.py | install execution failed. This is reported in the upstream project as part of pull request #81 https://github.com/stefankoegl/python-json-patch/pull/81 Since a release is not yet available with the required fix we must apply the fix as a patch. (From meta-openembedded commit: 3aa3c374ca7cd0850bdede6a404936737abb4068) Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-jsonpatch/Drop-support-for-EOL-Python-3.3.patch35
-rw-r--r--recipes-devtools/python/python-jsonpatch_1.21.bb4
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-jsonpatch/Drop-support-for-EOL-Python-3.3.patch b/recipes-devtools/python/python-jsonpatch/Drop-support-for-EOL-Python-3.3.patch
new file mode 100644
index 0000000..ccd8e12
--- /dev/null
+++ b/recipes-devtools/python/python-jsonpatch/Drop-support-for-EOL-Python-3.3.patch
@@ -0,0 +1,35 @@
+From 71bdeed8b49390ff14fe8f0434fc8a1038d89128 Mon Sep 17 00:00:00 2001
+From: Hugo <hugovk@users.noreply.github.com>
+Date: Tue, 16 Jan 2018 14:22:33 +0200
+Subject: [PATCH 1/4] Drop support for EOL Python 3.3
+
+Upstream-Status: Backport
+
+[MA: remove dev only files from patch]
+Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
+
+---
+ setup.py | 2 +-
+
+diff --git a/setup.py b/setup.py
+index 0776c41..471c433 100644
+--- a/setup.py
++++ b/setup.py
+@@ -58,7 +58,6 @@ CLASSIFIERS = [
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+- 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+@@ -81,5 +80,6 @@ setup(name=PACKAGE,
+ package_data={'': ['requirements.txt']},
+ scripts=['bin/jsondiff', 'bin/jsonpatch'],
+ classifiers=CLASSIFIERS,
++ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ **OPTIONS
+ )
+--
+2.7.4
+
diff --git a/recipes-devtools/python/python-jsonpatch_1.21.bb b/recipes-devtools/python/python-jsonpatch_1.21.bb
index 90cd318..2b253b5 100644
--- a/recipes-devtools/python/python-jsonpatch_1.21.bb
+++ b/recipes-devtools/python/python-jsonpatch_1.21.bb
@@ -2,3 +2,7 @@ inherit setuptools
require python-jsonpatch.inc
RDEPENDS_${PN} += "${PYTHON_PN}-re"
+
+SRC_URI += " \
+ file://Drop-support-for-EOL-Python-3.3.patch \
+"