aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-10-30 11:14:18 -0400
committerArmin Kuster <akuster808@gmail.com>2018-11-15 13:18:49 -0800
commitc806bcacc7e0c948896c1f6f055be53958b88987 (patch)
tree82acdffe5a2c95e836de06406442c2b8e2fa773f
parent92dfa0f27feba5ccf1d452b1ff90433b0fb3cd24 (diff)
downloadmeta-python2-c806bcacc7e0c948896c1f6f055be53958b88987.tar.gz
python-twisted: Add more python-twisted-* packages to the "meta" package
Whereas the python-twisted-core package is used to install the minimum components of python-twisted, the python-twisted package is essentially a 'meta' package which installs all of the python-twisted-* packages (used by folks that don't want to determine which components they are interested in). Add additional packages to the python-twisted 'meta' package. NOTE: that there are still modules of python-twisted which have not been ported to python3 (see src/twisted/python/_setup.py "notPortedModules") so the installed packages for py2 vs. py3 will not be the same (ie. python-twisted-news is only part of the py2 package). (From meta-openembedded commit: 46435c7e4b547292fefc5ff4bb5f111ead554039) Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-twisted.inc3
-rw-r--r--recipes-devtools/python/python-twisted_18.4.0.bb4
2 files changed, 7 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-twisted.inc b/recipes-devtools/python/python-twisted.inc
index 260909b..01616b1 100644
--- a/recipes-devtools/python/python-twisted.inc
+++ b/recipes-devtools/python/python-twisted.inc
@@ -49,9 +49,12 @@ RDEPENDS_${PN} = "\
${PN}-conch \
${PN}-mail \
${PN}-names \
+ ${PN}-pair \
+ ${PN}-protocols \
${PN}-runner \
${PN}-web \
${PN}-words \
+ ${PN}-zsh \
"
RDEPENDS_${PN}-core = "${PYTHON_PN}-core ${PYTHON_PN}-zopeinterface ${PYTHON_PN}-incremental ${PYTHON_PN}-constantly ${PYTHON_PN}-hyperlink ${PYTHON_PN}-automat"
diff --git a/recipes-devtools/python/python-twisted_18.4.0.bb b/recipes-devtools/python/python-twisted_18.4.0.bb
index 2be1709..5903db3 100644
--- a/recipes-devtools/python/python-twisted_18.4.0.bb
+++ b/recipes-devtools/python/python-twisted_18.4.0.bb
@@ -2,3 +2,7 @@ inherit pypi setuptools
require python-twisted.inc
RDEPENDS_${PN}-core += "${PYTHON_PN}-contextlib"
+
+RDEPENDS_${PN} += " \
+ ${PN}-news \
+"