aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Kizunov <sergey.kizunov@ni.com>2018-08-29 13:14:53 +0300
committerKhem Raj <raj.khem@gmail.com>2018-08-29 18:18:14 -0700
commitbe214d252e5e77f0233533497d9af708ea1a66e0 (patch)
treeea46fae6f04cbe9f69de21662fbb780b4ce5d28f
parentbbb9ca37134f5ce1373d23efea9c822c7cdb5fb5 (diff)
downloadmeta-python2-be214d252e5e77f0233533497d9af708ea1a66e0.tar.gz
python-pytest-tempdir: add recipe
Adds support for a predictable and repeatable temporary directory. (From meta-openembedded commit: f60b850edde6f6b11e252e1127538ed9aededcfb) Signed-off-by: Sergey Kizunov <sergey.kizunov@ni.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb b/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb
new file mode 100644
index 0000000..74030dc
--- /dev/null
+++ b/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Adds support for a predictable and repeatable temporary directory."
+HOMEPAGE = "https://github.com/saltstack/pytest-tempdir"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=8751a9cf4a70be4f02697a9b89e686ce"
+
+SRC_URI[md5sum] = "f87f2583f5f8aaca7203d57ada3948b5"
+SRC_URI[sha256sum] = "65ff815966ea6dfc07ca1b43747c9888a6d883971170e67b16290f9f50d434ea"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ python-pytest \
+ "