aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2018-08-02 20:27:02 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-03 09:34:29 -0700
commita1ef8b5257152fcf3a41700f7d7691afe5843e6b (patch)
treeb562cd2cb3d61907e4d96f188fb2956d693ff8e0
parent52130575c4d7ebeaa3721c1f57e6ed32560ab1ac (diff)
downloadmeta-python2-a1ef8b5257152fcf3a41700f7d7691afe5843e6b.tar.gz
python3-parse: Add recipe
Correct the license to MIT. The PyPI metadata says BSD, but the license text in the code is actually MIT. (From meta-openembedded commit: 4f39906e1c40cff080dae42abed8631b155e42c7) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-parse.inc14
-rw-r--r--recipes-devtools/python/python-parse_1.8.4.bb15
2 files changed, 16 insertions, 13 deletions
diff --git a/recipes-devtools/python/python-parse.inc b/recipes-devtools/python/python-parse.inc
new file mode 100644
index 0000000..fa55a93
--- /dev/null
+++ b/recipes-devtools/python/python-parse.inc
@@ -0,0 +1,14 @@
+SUMMARY = "Parse strings using a specification based on the Python format() syntax"
+HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://parse.py;beginline=1273;endline=1291;md5=5147afdd9b3615290ad8733f0137a1a1"
+
+SRC_URI[md5sum] = "fa69ab2fe846f9b183411391f7c6897b"
+SRC_URI[sha256sum] = "c3cdf6206f22aeebfa00e5b954fcfea13d1b2dc271c75806b6025b94fb490939"
+
+inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-logging \
+ "
diff --git a/recipes-devtools/python/python-parse_1.8.4.bb b/recipes-devtools/python/python-parse_1.8.4.bb
index c66d4c8..d31ccc7 100644
--- a/recipes-devtools/python/python-parse_1.8.4.bb
+++ b/recipes-devtools/python/python-parse_1.8.4.bb
@@ -1,13 +1,2 @@
-SUMMARY = "Parse strings using a specification based on the Python format() syntax"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://parse.py;beginline=1273;endline=1291;md5=5147afdd9b3615290ad8733f0137a1a1"
-
-SRC_URI[md5sum] = "fa69ab2fe846f9b183411391f7c6897b"
-SRC_URI[sha256sum] = "c3cdf6206f22aeebfa00e5b954fcfea13d1b2dc271c75806b6025b94fb490939"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-datetime \
- ${PYTHON_PN}-logging \
- "
+inherit setuptools
+require python-parse.inc