aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-09-20 22:37:12 +0000
committerKhem Raj <raj.khem@gmail.com>2018-09-24 11:49:45 -0700
commit508ec15b5207e7a77acc28581dd7254b938aeefd (patch)
treea13fb184b4908a316dea9f6054543b811f1f2e1e
parentd0d4b39c15bd4a84d6d72eba13b5af3bfc7069c8 (diff)
downloadmeta-python2-508ec15b5207e7a77acc28581dd7254b938aeefd.tar.gz
python-thrift: set downloadfilename to prevent conflicts with thrift itself
* I was building thrift-0.9.3 from meta-oe and do_fetch was failing with wrong checksum because my premirror already had thrift-0.9.3.tar.gz from python-thrift, unpacking the archives to find what's wrong revealed what's wrong: thrift-0.9.3.old/thrift-0.9.3/: PKG-INFO setup.cfg setup.py src thrift.egg-info thrift-0.9.3/thrift-0.9.3/: aclocal appveyor.yml build CMakeLists.txt compiler config.guess config.hin configure contrib debian doap.rdf install-sh lib ltmain.sh Makefile.in NOTICE rat_exclude sonar-project.properties tutorial aclocal.m4 bower.json CHANGES compile composer.json config.h config.sub configure.ac CONTRIBUTING.md depcomp doc json-schema.json LICENSE Makefile.am missing package.json README.md test ylwrap you can get the same by comparing: http://mirror.switch.ch/mirror/apache/dist/thrift/0.9.3/thrift-0.9.3.tar.gz http://sources.openembedded.org/thrift-0.9.3.tar.gz the later is the python-thrift one from: http://git.openembedded.org/meta-openembedded/commit/?id=39d738fcd6acd5b00b1f31be3a2b38e34f8b69e9 your premirror might already be polluted by this and thrift-0.10.0.tar.gz + thrift-0.11.0.tar.gz from: http://git.openembedded.org/meta-openembedded/commit/?id=e429a4df0a77b955a4cafcc75b99fbf18a98f833 http://git.openembedded.org/meta-openembedded/commit/?id=a6eaad61908f054c3b2e8f4a8dc772058594983f * this should be backported all the way to morty where the conflicting archive was introduced and manual cleanup on sources.openembedded.org will be needed as well (From meta-openembedded commit: 16dbfded41b9ee772f8f56e85098e7589a8b25c5) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-connectivity/python-thrift/python-thrift_0.11.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-connectivity/python-thrift/python-thrift_0.11.0.bb b/recipes-connectivity/python-thrift/python-thrift_0.11.0.bb
index 8047ec7..10cff42 100644
--- a/recipes-connectivity/python-thrift/python-thrift_0.11.0.bb
+++ b/recipes-connectivity/python-thrift/python-thrift_0.11.0.bb
@@ -7,6 +7,9 @@ SRC_URI[sha256sum] = "7d59ac4fdcb2c58037ebd4a9da5f9a49e3e034bf75b3f26d9fe48ba3d8
inherit pypi setuptools
+# Use different filename to prevent conflicts with thrift itself
+PYPI_SRC_URI_append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}"
+
RDEPENDS_${PN} += "\
${PYTHON_PN}-logging \
${PYTHON_PN}-six \