aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-27 13:07:32 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-28 09:36:28 -0700
commit137d04c0d0f30e6be55e51c6f3ca6c3aa2b9ab3a (patch)
tree34b9d1f28f7fa3c8d8c02b7b6adbd1a1386bdc88
parent05b3a4dd30dd6853116fea30c892759515f74582 (diff)
downloadmeta-python2-137d04c0d0f30e6be55e51c6f3ca6c3aa2b9ab3a.tar.gz
python{, 3}-grpcio-tools: update 1.8.4 -> 1.14.1
Align recipe for python protobuf code generator for gRPC with grpc itself and python-grpcio. (From meta-openembedded commit: d9309e44aa1d530c77ced19af1b4d2c5c0dbec6e) Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-grpcio-tools.inc16
-rw-r--r--recipes-devtools/python/python-grpcio-tools_1.14.1.bb2
-rw-r--r--recipes-devtools/python/python-grpcio-tools_1.8.4.bb17
3 files changed, 18 insertions, 17 deletions
diff --git a/recipes-devtools/python/python-grpcio-tools.inc b/recipes-devtools/python/python-grpcio-tools.inc
new file mode 100644
index 0000000..91cc62f
--- /dev/null
+++ b/recipes-devtools/python/python-grpcio-tools.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Google gRPC tools"
+HOMEPAGE = "http://www.grpc.io/"
+SECTION = "devel/python"
+
+DEPENDS_append = "${PYTHON_PN}-grpcio"
+RDEPENDS_${PN} = "${PYTHON_PN}-grpcio"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+
+inherit pypi
+
+SRC_URI[md5sum] = "b2fabfb54c7824c1e49a02de2aa6628e"
+SRC_URI[sha256sum] = "4ce5aa660d7884f23aac1eafa93b97a4c3e2b512edff871e91fdb6ee86ebd5ea"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/python/python-grpcio-tools_1.14.1.bb b/recipes-devtools/python/python-grpcio-tools_1.14.1.bb
new file mode 100644
index 0000000..5b19beb
--- /dev/null
+++ b/recipes-devtools/python/python-grpcio-tools_1.14.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-grpcio-tools.inc
diff --git a/recipes-devtools/python/python-grpcio-tools_1.8.4.bb b/recipes-devtools/python/python-grpcio-tools_1.8.4.bb
deleted file mode 100644
index 45e0cc1..0000000
--- a/recipes-devtools/python/python-grpcio-tools_1.8.4.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-DESCRIPTION = "Google gRPC tools"
-HOMEPAGE = "http://www.grpc.io/"
-SECTION = "devel/python"
-
-DEPENDS = "python-grpcio"
-RDEPENDS_${PN} = "python-grpcio"
-
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
-
-inherit pypi setuptools
-
-SRC_URI[md5sum] = "e04e65afe60410cf178ff2698f052a7c"
-SRC_URI[sha256sum] = "edc84c09039d3a01012ccd97450abd06ee6b980710f6d9f191b50deb6774a75c"
-
-# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
-BBCLASSEXTEND = "native"