aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-27 13:07:33 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-27 10:53:58 -0700
commitda5a541d5e5b1bad466d2c6fefb2c347a9ecef41 (patch)
tree7b887c10306016cb4a5457c5e0fddc65efdc6b0e
parentc8c42572b91f92492357170f0c33cb3f5f9a75c1 (diff)
downloadmeta-python2-da5a541d5e5b1bad466d2c6fefb2c347a9ecef41.tar.gz
python{, 3}-pint: add recipes for python2 and python3
Add recipe for physical quantities module for python2 and python3 infrastructure of Yocto. (From meta-openembedded commit: c591e5d84ce6820aff7e24a8a91956b2f1e87dd6) Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pint.inc15
-rw-r--r--recipes-devtools/python/python-pint_0.8.1.bb2
2 files changed, 17 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pint.inc b/recipes-devtools/python/python-pint.inc
new file mode 100644
index 0000000..53f7783
--- /dev/null
+++ b/recipes-devtools/python/python-pint.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "Interval arithmetic for Python"
+HOMEPAGE = "https://github.com/AlexandreDecan/python-intervals"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+
+PYPI_PACKAGE := "Pint"
+
+inherit pypi
+
+SRC_URI[md5sum] = "e1f80f3f8fc4e61f68ad3912db26b3a8"
+SRC_URI[sha256sum] = "afcf31443a478c32bbac4b00337ee9026a13d0e2ac83d30c79151462513bb0d4"
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-pint_0.8.1.bb b/recipes-devtools/python/python-pint_0.8.1.bb
new file mode 100644
index 0000000..480f088
--- /dev/null
+++ b/recipes-devtools/python/python-pint_0.8.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pint.inc