aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoris Offouga <offougajoris@gmail.com>2018-10-26 10:45:22 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-26 21:08:43 -0700
commit5bf6af23d83ec57670baf09cf97625ef68723b6a (patch)
treeb8e579b28de179e0e4ae728a58554e43c62493fa
parentcc7570f159e0b7e260576feb3c45a1390136789e (diff)
downloadmeta-python2-5bf6af23d83ec57670baf09cf97625ef68723b6a.tar.gz
] Add recipes for django rest framework
(From meta-openembedded commit: 3ad039f79a48926e81522a6f0057885c56d32786) Signed-off-by: Joris Offouga <offougajoris@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-djangorestframework.inc16
-rw-r--r--recipes-devtools/python/python-djangorestframework_3.9.0.bb2
2 files changed, 18 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-djangorestframework.inc b/recipes-devtools/python/python-djangorestframework.inc
new file mode 100644
index 0000000..8551a83
--- /dev/null
+++ b/recipes-devtools/python/python-djangorestframework.inc
@@ -0,0 +1,16 @@
+SUMMARY = "djangorestframework"
+DESCRIPTION = "pip3 install djangorestframework"
+HOMEPAGE = "https://pypi.python.org/pypi/djangorestframework"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=7879a5a716147a784f7e524c9cf103c1"
+
+SRC_URI[md5sum] = "0d481bf8dbb87bb927b46798edc1a9bd"
+SRC_URI[sha256sum] = "607865b0bb1598b153793892101d881466bd5a991de12bd6229abb18b1c86136"
+PYPI_PACKAGE = "djangorestframework"
+
+inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-django \
+" \ No newline at end of file
diff --git a/recipes-devtools/python/python-djangorestframework_3.9.0.bb b/recipes-devtools/python/python-djangorestframework_3.9.0.bb
new file mode 100644
index 0000000..540d12d
--- /dev/null
+++ b/recipes-devtools/python/python-djangorestframework_3.9.0.bb
@@ -0,0 +1,2 @@
+require python-djangorestframework.inc
+inherit setuptools \ No newline at end of file