aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBinghua Guan <freebendy@gmail.com>2018-08-08 13:43:22 +0000
committerKhem Raj <raj.khem@gmail.com>2018-08-10 12:51:21 -0700
commit2a5c03ede75f8ab4be6a9c817117a9eaa3136e05 (patch)
treec676112aa4794890bec9e888438c8ce3c4f66417
parent50c601e239d99f9208ea86b62987fb9bab4a20aa (diff)
downloadmeta-python2-2a5c03ede75f8ab4be6a9c817117a9eaa3136e05.tar.gz
meta-python: add python-pycodestyle recipe
(From meta-openembedded commit: 98382d5c77900b504360e48ebdf4a4ef0082b9e1) Signed-off-by: Binghua Guan <freebendy@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pycodestyle.inc12
-rw-r--r--recipes-devtools/python/python-pycodestyle_2.4.0.bb4
2 files changed, 16 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pycodestyle.inc b/recipes-devtools/python/python-pycodestyle.inc
new file mode 100644
index 0000000..c0e46b7
--- /dev/null
+++ b/recipes-devtools/python/python-pycodestyle.inc
@@ -0,0 +1,12 @@
+SUMMARY = "Python style guide checker (formly called pep8)"
+HOMEPAGE = "https://pypi.org/project/pycodestyle"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=01831ddbaf398471da3cc87f5037e822"
+
+SRC_URI[md5sum] = "85bbebd2c90d2f833c1db467d4d0e9a3"
+SRC_URI[sha256sum] = "cbfca99bd594a10f674d0cd97a3d802a1fdef635d4361e1a2658de47ed261e3a"
+
+inherit pypi
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/python/python-pycodestyle_2.4.0.bb b/recipes-devtools/python/python-pycodestyle_2.4.0.bb
new file mode 100644
index 0000000..7c736e7
--- /dev/null
+++ b/recipes-devtools/python/python-pycodestyle_2.4.0.bb
@@ -0,0 +1,4 @@
+inherit setuptools
+require python-pycodestyle.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-lang"