aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2018-08-02 20:27:03 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-03 09:34:29 -0700
commit047f27ea0098dbc334e7a6d81ccc496c090b4910 (patch)
tree603a71bea164f2a8840703fd6ff4637cdf05fb1f
parenta1ef8b5257152fcf3a41700f7d7691afe5843e6b (diff)
downloadmeta-python2-047f27ea0098dbc334e7a6d81ccc496c090b4910.tar.gz
python-parse-type: Add Python 3 recipe
Clarify license from BSD to BSD-3-Clause. (From meta-openembedded commit: 4dc3c05e72fb97800f3902b8a634f1df5a27193f) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-parse-type.inc12
-rw-r--r--recipes-devtools/python/python-parse-type_0.4.2.bb13
2 files changed, 14 insertions, 11 deletions
diff --git a/recipes-devtools/python/python-parse-type.inc b/recipes-devtools/python/python-parse-type.inc
new file mode 100644
index 0000000..4549ec9
--- /dev/null
+++ b/recipes-devtools/python/python-parse-type.inc
@@ -0,0 +1,12 @@
+SUMMARY = "Simplifies building parse types based on the parse module"
+HOMEPAGE = "https://github.com/jenisys/parse_type"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d07323820cca0f1d192cbbf8a0516f95"
+
+SRC_URI[md5sum] = "b5fa59e45965d1b2896023742df2e707"
+SRC_URI[sha256sum] = "f596bdc75d3dd93036fbfe3d04127da9f6df0c26c36e01e76da85adef4336b3c"
+
+PYPI_PACKAGE = "parse_type"
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-parse"
diff --git a/recipes-devtools/python/python-parse-type_0.4.2.bb b/recipes-devtools/python/python-parse-type_0.4.2.bb
index b516c59..8e10e80 100644
--- a/recipes-devtools/python/python-parse-type_0.4.2.bb
+++ b/recipes-devtools/python/python-parse-type_0.4.2.bb
@@ -1,11 +1,2 @@
-SUMMARY = "Simplifies building parse types based on the parse module"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d07323820cca0f1d192cbbf8a0516f95"
-PYPI_PACKAGE = "parse_type"
-
-SRC_URI[md5sum] = "b5fa59e45965d1b2896023742df2e707"
-SRC_URI[sha256sum] = "f596bdc75d3dd93036fbfe3d04127da9f6df0c26c36e01e76da85adef4336b3c"
-
-RDEPENDS_${PN} += "python-parse"
-
-inherit pypi setuptools
+inherit setuptools
+require python-parse-type.inc