aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-15 15:21:58 -0500
committerArmin Kuster <akuster808@gmail.com>2018-03-12 14:38:11 -0700
commite618d218a81e9cc5666334c84ad7bb5c2b9c7b4b (patch)
treee3a1416db6b17887e5d170b51b30837ca6c9ff18
parent82637a54a768e112381fabbd833d95529a7d23f5 (diff)
downloadmeta-python2-e618d218a81e9cc5666334c84ad7bb5c2b9c7b4b.tar.gz
python-incremental: add an initial recipe for version 17.5.0
(From meta-openembedded commit: 9528454be4f407f7f3a96458c9a05537a2f1d43f) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-incremental.inc14
-rw-r--r--recipes-devtools/python/python-incremental_17.5.0.bb2
2 files changed, 16 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-incremental.inc b/recipes-devtools/python/python-incremental.inc
new file mode 100644
index 0000000..3675458
--- /dev/null
+++ b/recipes-devtools/python/python-incremental.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "Incremental is a small library that versions your Python projects"
+HOMEPAGE = "https://github.com/twisted/incremental"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
+
+SRC_URI[md5sum] = "602746e0d438e075a5a9e0678140bba2"
+SRC_URI[sha256sum] = "7b751696aaf36eebfab537e458929e194460051ccad279c72b755a167eebd4b3"
+
+inherit pypi
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-twisted \
+ ${PYTHON_PN}-click \
+"
diff --git a/recipes-devtools/python/python-incremental_17.5.0.bb b/recipes-devtools/python/python-incremental_17.5.0.bb
new file mode 100644
index 0000000..139ac0c
--- /dev/null
+++ b/recipes-devtools/python/python-incremental_17.5.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-incremental.inc