aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-09-19 10:12:06 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-22 22:50:44 +0000
commit4b12d3a9b2be76a6939b886e3555e163ec1aa57c (patch)
treeecc520513ec1dc60eb840a6836ddc7de2393ec5c
parent075238f2c8fa2e969dd6985e72277678522fc30b (diff)
downloadmeta-python2-4b12d3a9b2be76a6939b886e3555e163ec1aa57c.tar.gz
python-grpcio: update to version 1.6.0
(From meta-openembedded commit: 9c9bde5cd7d0a911de1ebe5c253a12827683bb9c) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch4
-rw-r--r--recipes-devtools/python/python-grpcio_1.6.0.bb (renamed from recipes-devtools/python/python-grpcio_1.4.0.bb)6
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index 3686144..3abbc6d 100644
--- a/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -26,8 +26,8 @@ index cb85273..f79878d 100644
elif 'win32' in sys.platform:
EXTRA_ENV_COMPILE_ARGS += ' -D_PYTHON_MSVC'
elif "linux" in sys.platform:
-- EXTRA_ENV_COMPILE_ARGS += ' -std=c++11 -std=gnu99 -fvisibility=hidden -fno-wrapv'
-+ EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv'
+- EXTRA_ENV_COMPILE_ARGS += ' -std=c++11 -std=gnu99 -fvisibility=hidden -fno-wrapv -fno-exceptions'
++ EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions'
elif "darwin" in sys.platform:
EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv'
diff --git a/recipes-devtools/python/python-grpcio_1.4.0.bb b/recipes-devtools/python/python-grpcio_1.6.0.bb
index 2446411..7155f42 100644
--- a/recipes-devtools/python/python-grpcio_1.4.0.bb
+++ b/recipes-devtools/python/python-grpcio_1.6.0.bb
@@ -18,8 +18,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec
inherit pypi setuptools
-SRC_URI[md5sum] = "d882ae4eeef4f32ac9c1d32052bf05ad"
-SRC_URI[sha256sum] = "a3a213a4c24b5c572b386d752e3b74a3f1b8fa5d03c07b6166fa39f3a6cdef34"
+SRC_URI[md5sum] = "c91b8c105ff4163b41790f3b63db92e1"
+SRC_URI[sha256sum] = "6cd793d515ec53587a8968f2a53647f1449763ad06be0d287e3c1e47418e1e50"
-# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
+# For usage in other recipes when compiling protobuf files (e.g. by grpcio-tools)
BBCLASSEXTEND = "native"