aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-09-27 00:14:22 +1300
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-04 14:53:25 +0000
commit13807c9a33c10bb4cc7518f0d88f7da087039d1a (patch)
treea1720045312b5282eb427ba894a0ae2ad9ade49e
parent5cab1b79b0bbfafcd9a5c473841aa9265b3e52cc (diff)
downloadmeta-python2-13807c9a33c10bb4cc7518f0d88f7da087039d1a.tar.gz
python-pyfirmata: move in from meta-intel-iot-middleware and upgrade
The following improvements have been made over the recipe that was in meta-intel-iot-middleware (a layer which is no longer actively maintained): * Upgrade to 1.0.3 * Inherit from setuptools instead of distutils since that changed with the upgrade * Inherit pypi and also provide Python 3 version * Use the correct LICENSE (changed BSD -> MIT back at version 0.9.5) * Set short description in SUMMARY instead of DESCRIPTION (From meta-openembedded commit: 9de311127b525f1b001c9847ffe434c7abfadb79) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pyfirmata.inc13
-rw-r--r--recipes-devtools/python/python-pyfirmata_1.0.3.bb3
2 files changed, 16 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyfirmata.inc b/recipes-devtools/python/python-pyfirmata.inc
new file mode 100644
index 0000000..2365379
--- /dev/null
+++ b/recipes-devtools/python/python-pyfirmata.inc
@@ -0,0 +1,13 @@
+SUMMARY = "A Python interface for the Firmata protocol"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=84ddcef430b7c44caa22b2ff4b37a3df"
+PYPI_PACKAGE = "pyFirmata"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-pyserial \
+"
+
+SRC_URI[md5sum] = "ee4c23ca5c35d3091d550a63540811a3"
+SRC_URI[sha256sum] = "b54d49d66a9d93c1ef9c72ca01264414cb2de177baac116c12d5cce0c380160c"
+
+inherit pypi
diff --git a/recipes-devtools/python/python-pyfirmata_1.0.3.bb b/recipes-devtools/python/python-pyfirmata_1.0.3.bb
new file mode 100644
index 0000000..d77e0f3
--- /dev/null
+++ b/recipes-devtools/python/python-pyfirmata_1.0.3.bb
@@ -0,0 +1,3 @@
+inherit setuptools
+require python-pyfirmata.inc
+