aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-15 15:21:59 -0500
committerArmin Kuster <akuster808@gmail.com>2018-03-12 14:38:11 -0700
commit00a302607f26b1bbdfd25acb3679cea59e336903 (patch)
tree018a435ae845d9bfa855c95964d0831afb062550
parente618d218a81e9cc5666334c84ad7bb5c2b9c7b4b (diff)
downloadmeta-python2-00a302607f26b1bbdfd25acb3679cea59e336903.tar.gz
python-hyperlink: add a recipe for version 17.3.1
(From meta-openembedded commit: 60dfa8cb904b2f18167123b17e3d73c40cbaa936) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-hyperlink.inc17
-rw-r--r--recipes-devtools/python/python-hyperlink_17.3.1.bb2
2 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-hyperlink.inc b/recipes-devtools/python/python-hyperlink.inc
new file mode 100644
index 0000000..2b5b0a0
--- /dev/null
+++ b/recipes-devtools/python/python-hyperlink.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "A featureful, correct URL for Python"
+HOMEPAGE = "https://github.com/python-hyper/hyperlink"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3893d4ed05dcc823f8ed685a9ea19bcb"
+
+SRC_URI[md5sum] = "eaccb9845b559817e838846669cbc68a"
+SRC_URI[sha256sum] = "bc4ffdbde9bdad204d507bd8f554f16bba82dd356f6130cb16f41422909c33bc"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-stringold ${PYTHON_PN}-netclient"
+
+PACKAGES =. "${PN}-test "
+
+FILES_${PN}-test += " \
+ ${PYTHON_SITEPACKAGES_DIR}/hyperlinkt/test \
+"
diff --git a/recipes-devtools/python/python-hyperlink_17.3.1.bb b/recipes-devtools/python/python-hyperlink_17.3.1.bb
new file mode 100644
index 0000000..59a9a5c
--- /dev/null
+++ b/recipes-devtools/python/python-hyperlink_17.3.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-hyperlink.inc