aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-15 15:21:56 -0500
committerArmin Kuster <akuster808@gmail.com>2018-03-12 14:38:11 -0700
commite0ce00249d44d2cc6e11089568e892cae94d194e (patch)
tree4935525601df5c2b861ebb8f347020b5ef26cbe3
parent41de93cc8581e30943ff52f6985b7f875c738f73 (diff)
downloadmeta-python2-e0ce00249d44d2cc6e11089568e892cae94d194e.tar.gz
python-automat: add an initial recipe for version 0.6.0
(From meta-openembedded commit: b1f5f1846899474db89e83dfff4c10eb778b6caf) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-automat.inc16
-rw-r--r--recipes-devtools/python/python-automat_0.6.0.bb2
2 files changed, 18 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-automat.inc b/recipes-devtools/python/python-automat.inc
new file mode 100644
index 0000000..1ac5d3b
--- /dev/null
+++ b/recipes-devtools/python/python-automat.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Self-service finite-state machines for the programmer on the go"
+HOMEPAGE = "https://github.com/glyph/Automat"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477"
+
+SRC_URI[md5sum] = "ad7bba58d262d8956d732330cb5ef53d"
+SRC_URI[sha256sum] = "3c1fd04ecf08ac87b4dd3feae409542e9bf7827257097b2b6ed5692f69d6f6a8"
+
+PYPI_PACKAGE = "Automat"
+
+inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-six \
+"
diff --git a/recipes-devtools/python/python-automat_0.6.0.bb b/recipes-devtools/python/python-automat_0.6.0.bb
new file mode 100644
index 0000000..8ac8c9c
--- /dev/null
+++ b/recipes-devtools/python/python-automat_0.6.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-automat.inc