aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@nextrem.ch>2017-10-04 14:03:49 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-15 17:29:30 +0000
commitc43a306ae75063c14e1c253c6520e68e001bc4ca (patch)
treed9af3acb5bb08d8160415317477a709986df2ddf
parente9edfce2abfb3c56c1bd81217170f4f3b8645047 (diff)
downloadmeta-python2-c43a306ae75063c14e1c253c6520e68e001bc4ca.tar.gz
python3-ujson: support Python 3
(From meta-openembedded commit: 36f873f8d59bd8b2afa962fce51b546f281c866f) Signed-off-by: Pascal Bach <pascal.bach@nextrem.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-ujson.inc15
-rw-r--r--recipes-devtools/python/python-ujson_1.35.bb17
2 files changed, 17 insertions, 15 deletions
diff --git a/recipes-devtools/python/python-ujson.inc b/recipes-devtools/python/python-ujson.inc
new file mode 100644
index 0000000..9654d5a
--- /dev/null
+++ b/recipes-devtools/python/python-ujson.inc
@@ -0,0 +1,15 @@
+SUMMARY = "Ultra fast JSON encoder and decoder for Python"
+DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;startline=8;endline=9;md5=4f369b3c3c290b4aede8796a4065e5ab"
+
+SRC_URI[md5sum] = "42f77b0cce686dfa4da2e68480b1dd24"
+SRC_URI[sha256sum] = "f66073e5506e91d204ab0c614a148d5aa938bdbf104751be66f8ad7a222f5f86"
+
+inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+ "
diff --git a/recipes-devtools/python/python-ujson_1.35.bb b/recipes-devtools/python/python-ujson_1.35.bb
index 238dc92..b3c6ae6 100644
--- a/recipes-devtools/python/python-ujson_1.35.bb
+++ b/recipes-devtools/python/python-ujson_1.35.bb
@@ -1,15 +1,2 @@
-SUMMARY = "Ultra fast JSON encoder and decoder for Python"
-DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
-
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://PKG-INFO;startline=8;endline=9;md5=4f369b3c3c290b4aede8796a4065e5ab"
-
-SRC_URI[md5sum] = "42f77b0cce686dfa4da2e68480b1dd24"
-SRC_URI[sha256sum] = "f66073e5506e91d204ab0c614a148d5aa938bdbf104751be66f8ad7a222f5f86"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-datetime \
- ${PYTHON_PN}-numbers \
- "
+inherit setuptools
+require python-ujson.inc