aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:24 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:38 +0200
commit52aa9b5dc78729f7556e1003ef3266f33eca59ad (patch)
tree2981bd02be28a10c11f2aa4efa068fbf6d71bbe8
parent5c3b8eeb01cfb354046751d29836c5154f90813a (diff)
downloadmeta-python2-52aa9b5dc78729f7556e1003ef3266f33eca59ad.tar.gz
python-pretend: Extend recipe to support Python 3
- Add Python 3 recipe - Add native and nativesdk to BBCLASSEXTEND (From meta-openembedded commit: 1d68defca0ddf4225da978bd7a2f36cee6cf89da) Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pretend.inc8
-rw-r--r--recipes-devtools/python/python-pretend_1.0.8.bb8
2 files changed, 9 insertions, 7 deletions
diff --git a/recipes-devtools/python/python-pretend.inc b/recipes-devtools/python/python-pretend.inc
new file mode 100644
index 0000000..2d21cc4
--- /dev/null
+++ b/recipes-devtools/python/python-pretend.inc
@@ -0,0 +1,8 @@
+SUMMARY = "A library for stubbing in Python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=411780c0b7fa756753e94affeee5bc99"
+
+SRC_URI[md5sum] = "7147050a95c9f494248557b42b58ad79"
+SRC_URI[sha256sum] = "930f2c1e18503e8f8c403abe2e02166c4a881941745147e712cdd4f49f3fb964"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/python/python-pretend_1.0.8.bb b/recipes-devtools/python/python-pretend_1.0.8.bb
index ddc7b62..73b8ed4 100644
--- a/recipes-devtools/python/python-pretend_1.0.8.bb
+++ b/recipes-devtools/python/python-pretend_1.0.8.bb
@@ -1,8 +1,2 @@
-SUMMARY = "A library for stubbing in Python"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=411780c0b7fa756753e94affeee5bc99"
-
-SRC_URI[md5sum] = "7147050a95c9f494248557b42b58ad79"
-SRC_URI[sha256sum] = "930f2c1e18503e8f8c403abe2e02166c4a881941745147e712cdd4f49f3fb964"
-
inherit pypi setuptools
+require python-pretend.inc