aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-04-27 14:14:54 -0700
committerArmin Kuster <akuster808@gmail.com>2018-09-05 08:29:39 -0700
commitb85198286acc2c7a743e96f7fb152e9e11d25f5b (patch)
treee4e9a9cd9ab2b037fe946e87df6f584b87d33f41
parent63ba344ff4aed8b04650aff90060c60ec371c78c (diff)
downloadmeta-python2-rocko.tar.gz
python-evdev: Use target header to generate ecodes.crocko-nextrocko
ecodes.c is generated file and if we do not specify the linux input headers it happiliy defaults to /usr/include/ to look for these headers while emitting code for ecodes.c which can cause gripes when build systems kernel UAPI is different than the target kernel. Mysterious build errors or even worse runtime errors can start to appear. e.g. | evdev/ecodes.c:603:29: error: 'KEY_ROTATE_LOCK_TOGGLE' undeclared (first use in this function); did you mean 'KEY_ATTENDANT_TOGGLE'? (From meta-openembedded commit: d23612ff10eb6f43cd8e13d4c03fe8d9d38898fd) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> [Handel applied for rocko context] Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-evdev_0.7.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-evdev_0.7.0.bb b/recipes-devtools/python/python-evdev_0.7.0.bb
index 0875da4..0940b00 100644
--- a/recipes-devtools/python/python-evdev_0.7.0.bb
+++ b/recipes-devtools/python/python-evdev_0.7.0.bb
@@ -6,6 +6,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
SRC_URI[md5sum] = "c7e855ae9f97f869a59e75b29f05ce74"
SRC_URI[sha256sum] = "57edafc469a414f58b51af1bfb9ee2babb9f626dd2df530d71c1176871850aa1"
+do_compile_prepend() {
+ rm -rf ${S}/evdev/ecodes.c
+}
+
+DISTUTILS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
+
+
inherit pypi setuptools
RDEPENDS_${PN} += "\