aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2017-04-06 14:05:21 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-18 14:21:38 +0200
commitf79da0464a92c580a233fed2757a085d84caf255 (patch)
tree2c8b5716c92d30cd0a1905bae9b2e47b47df4a1e
parenteeddbb975f3e147018dcfb5360a09eebd67a51a2 (diff)
downloadmeta-python2-f79da0464a92c580a233fed2757a085d84caf255.tar.gz
python-paho-mqtt: make recipe available as python3 version
(From meta-openembedded commit: 4175dc4a8b6a5c452133dbc149b0b77b5aed13cb) Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-paho-mqtt.inc14
-rw-r--r--recipes-devtools/python/python-paho-mqtt_1.2.bb16
2 files changed, 16 insertions, 14 deletions
diff --git a/recipes-devtools/python/python-paho-mqtt.inc b/recipes-devtools/python/python-paho-mqtt.inc
new file mode 100644
index 0000000..7ff3fb2
--- /dev/null
+++ b/recipes-devtools/python/python-paho-mqtt.inc
@@ -0,0 +1,14 @@
+SUMMARY = "MQTT version 3.1/3.1.1 client library"
+LICENSE = "EPL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eb48c6ee2cb9f5b8b9fe75e6f817bdfc"
+SRCNAME = "paho-mqtt"
+
+inherit pypi
+SRC_URI[md5sum] = "241150b3fcb920ddca4d33181f3238b1"
+SRC_URI[sha256sum] = "9100a6aa706ab699d414ec02705a21eb66f436184691d0bf1f2a85a6213c6c1f"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-threading \
+"
diff --git a/recipes-devtools/python/python-paho-mqtt_1.2.bb b/recipes-devtools/python/python-paho-mqtt_1.2.bb
index c8acfc5..f369b2e 100644
--- a/recipes-devtools/python/python-paho-mqtt_1.2.bb
+++ b/recipes-devtools/python/python-paho-mqtt_1.2.bb
@@ -1,15 +1,3 @@
-SUMMARY = "MQTT version 3.1/3.1.1 client library"
-LICENSE = "EPL-1.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eb48c6ee2cb9f5b8b9fe75e6f817bdfc"
-SRCNAME = "paho-mqtt"
+inherit setuptools
+require python-paho-mqtt.inc
-inherit pypi setuptools
-
-RDEPENDS_${PN} = "\
- python-math \
- python-io \
- python-threading \
-"
-
-SRC_URI[md5sum] = "241150b3fcb920ddca4d33181f3238b1"
-SRC_URI[sha256sum] = "9100a6aa706ab699d414ec02705a21eb66f436184691d0bf1f2a85a6213c6c1f"