aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-04-21 17:08:17 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-26 20:13:28 +0200
commitf09a5d5f484c31b0f65c694e84673b9111dc9b54 (patch)
tree00355f8d888820f6720a280f9f12e752de440f9e
parentb884f843127ee127ca0329fe03aef52e31b9c07d (diff)
downloadmeta-python2-f09a5d5f484c31b0f65c694e84673b9111dc9b54.tar.gz
python-snimpy: add new recipe
Snimpy is a Python-based tool providing a simple interface to build SNMP query. (From meta-openembedded commit: f420757d1c31dc2c752321e7589357d25d6ce9d8) Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-snimpy_0.8.11.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-snimpy_0.8.11.bb b/recipes-devtools/python/python-snimpy_0.8.11.bb
new file mode 100644
index 0000000..cbdc6bd
--- /dev/null
+++ b/recipes-devtools/python/python-snimpy_0.8.11.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Interactive SNMP tool"
+DESCRIPTION = "Snimpy is a Python-based tool providing a simple interface to build SNMP query"
+HOMEPAGE = "https://pypi.python.org/pypi/snimpy"
+SECTION = "devel/python"
+
+DEPENDS = "libsmi python-cffi-native python-vcversioner-native"
+
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://docs/license.rst;md5=7c53ab2d1240828625c3e093d049d4f4"
+
+SRCNAME = "snimpy"
+
+SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "7f6270ce2e7206df165602e66d5ceb96"
+SRC_URI[sha256sum] = "10410614c7bff1053ca65bd760ce919f1a074f4988b857df4c57cf35847922b0"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "python-cffi \
+ python-pycparser \
+ python-pysnmp \
+ python-setuptools \
+"