aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2017-03-30 09:27:21 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-05 19:28:31 +0200
commiteeddbb975f3e147018dcfb5360a09eebd67a51a2 (patch)
tree82f2c0fa9e64ac58fcc05d7da7bfb8761a2c899c
parent5c815ffb98e37a13908dbc412ef6098897a7497c (diff)
downloadmeta-python2-eeddbb975f3e147018dcfb5360a09eebd67a51a2.tar.gz
python-smbus: upgrade to 3.1.2
Upgrade to 3.1.2 and use Yocto source mirror to follow commit f76fe46e098d ("i2c-tools: point SRC_URI at Yocto source mirrors") in OpenEmbedded cores i2c-tools recipe. With the upgrade to i2c-tools 3.1.2 Python 3 support has been added. To support Python 3 add a common recipe for all common information and one for each supported Python version 2 and 3. (From meta-openembedded commit: ad81891ee769a25a3fae596d4187bc4181805526) Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-smbus.inc (renamed from recipes-devtools/python/python-smbus_3.1.1.bb)10
-rw-r--r--recipes-devtools/python/python-smbus_3.1.2.bb2
2 files changed, 6 insertions, 6 deletions
diff --git a/recipes-devtools/python/python-smbus_3.1.1.bb b/recipes-devtools/python/python-smbus.inc
index df47df6..ded30ce 100644
--- a/recipes-devtools/python/python-smbus_3.1.1.bb
+++ b/recipes-devtools/python/python-smbus.inc
@@ -2,14 +2,12 @@ SUMMARY = "Set of i2c tools for linux - Python module"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://smbusmodule.c;startline=1;endline=17;md5=fa24df321a520ff8e10f203425ab9fa8"
-SRC_URI = "http://dl.lm-sensors.org/i2c-tools/releases/i2c-tools-${PV}.tar.bz2 \
+SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/i2c-tools-${PV}.tar.bz2 \
"
-SRC_URI[md5sum] = "0fdbff53ebd0b8d9249256d6c56480b1"
-SRC_URI[sha256sum] = "14d4d7d60d1c12e43f2befe239c682a5c44c27682f153d4b58c1e392d2db1700"
+SRC_URI[md5sum] = "7104a1043d11a5e2c7b131614eb1b962"
+SRC_URI[sha256sum] = "db5e69f2e2a6e3aa2ecdfe6a5f490b149c504468770f58921c8c5b8a7860a441"
-DEPENDS = "i2c-tools"
-
-inherit distutils
+DEPENDS += "i2c-tools"
S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/"
diff --git a/recipes-devtools/python/python-smbus_3.1.2.bb b/recipes-devtools/python/python-smbus_3.1.2.bb
new file mode 100644
index 0000000..1b95778
--- /dev/null
+++ b/recipes-devtools/python/python-smbus_3.1.2.bb
@@ -0,0 +1,2 @@
+inherit distutils
+require python-smbus.inc