aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2017-04-14 18:09:08 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-24 10:59:27 +0200
commite785d1f5020706611200858e925b7103f7329a2d (patch)
tree83f6be07297c42a3b6aa1ae7b7f9722d3ba5dc70
parent6c79675cb3130a19bd050168c0b6313ac885373c (diff)
downloadmeta-python2-e785d1f5020706611200858e925b7103f7329a2d.tar.gz
python-can: add initial recipe for version 1.5.2
Add initial recipe for python-can library which provides controller area network support for Python 2/3. (From meta-openembedded commit: 60885e3223ad811c2b4185eb6a22fa0cdb0d082a) Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-can.inc9
-rw-r--r--recipes-devtools/python/python-can_1.5.2.bb4
2 files changed, 13 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-can.inc b/recipes-devtools/python/python-can.inc
new file mode 100644
index 0000000..1878f31
--- /dev/null
+++ b/recipes-devtools/python/python-can.inc
@@ -0,0 +1,9 @@
+SUMMARY = "Controller Area Network (CAN) interface module for Python"
+SECTION = "devel/python"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=38138baa100d7259934590850bc0406e"
+
+SRC_URI[md5sum] = "f653aecf8b9034bbba32cc04ca6a7b6d"
+SRC_URI[sha256sum] = "edabb426e6cd11c2dc7a98980340135aa0eb02143b0d51bf14e3e6178c131cc3"
+
+PYPI_PACKAGE="python-can"
diff --git a/recipes-devtools/python/python-can_1.5.2.bb b/recipes-devtools/python/python-can_1.5.2.bb
new file mode 100644
index 0000000..ec81a9e
--- /dev/null
+++ b/recipes-devtools/python/python-can_1.5.2.bb
@@ -0,0 +1,4 @@
+require python-can.inc
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "python-sqlite3"