aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-13 17:15:51 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-24 11:00:54 +0200
commitcfd79c8e1af42dbefadc8c08d7b192df1caba1e8 (patch)
tree10211e6f69395c52e7a558d66a6884efc299c070
parent828567dbe9c45ba1dc80e86392ed867ab2df8f5f (diff)
downloadmeta-python2-cfd79c8e1af42dbefadc8c08d7b192df1caba1e8.tar.gz
python-lxml,python3-lxml: Fix libxslt format warnings
Found with clang (From meta-openembedded commit: 07bbd665e6f22e133964c20326c2ec60a7e2841f) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch40
-rw-r--r--recipes-devtools/python/python-lxml_3.7.3.bb4
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch b/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch
new file mode 100644
index 0000000..efaecd6
--- /dev/null
+++ b/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch
@@ -0,0 +1,40 @@
+From f8d2c3394767025b3b27b71248b3ecb50480cde7 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 13 Apr 2017 17:10:45 -0700
+Subject: [PATCH] lxml.etree: Add empty variadic argument
+
+format checker says that argument 4 is a printf formatted argument
+but there is no more arguments to follow
+
+Fixes libxslt format warnings
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/lxml/lxml.etree.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/lxml/lxml.etree.c b/src/lxml/lxml.etree.c
+index d482091..faab06c 100644
+--- a/src/lxml/lxml.etree.c
++++ b/src/lxml/lxml.etree.c
+@@ -186086,7 +186086,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p
+ * except:
+ */
+ __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 228, __pyx_L18_except_error)
+- xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26);
++ xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, "");
+
+ /* "src/lxml/xsltext.pxi":229
+ * c_inst_node.name, _cstr(e))
+@@ -186136,7 +186136,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p
+ * except:
+ */
+ __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 234, __pyx_L18_except_error)
+- xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26);
++ xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, "");
+
+ /* "src/lxml/xsltext.pxi":235
+ * "Error executing extension element '%s'", c_inst_node.name)
+--
+2.12.2
+
diff --git a/recipes-devtools/python/python-lxml_3.7.3.bb b/recipes-devtools/python/python-lxml_3.7.3.bb
index 81ccb12..5c93a3f 100644
--- a/recipes-devtools/python/python-lxml_3.7.3.bb
+++ b/recipes-devtools/python/python-lxml_3.7.3.bb
@@ -1,2 +1,6 @@
inherit setuptools
require python-lxml.inc
+
+SRC_URI = "${PYPI_SRC_URI} \
+ file://0001-lxml.etree-Add-empty-variadic-argument.patch \
+ "