aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-04-21 17:08:16 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-26 20:13:28 +0200
commitb884f843127ee127ca0329fe03aef52e31b9c07d (patch)
tree07b3131743bdb8fa5e998a58a1f77e15f5ea7ca9
parentb9c9cd47bc6ece8f847b982ae47a4dee92709112 (diff)
downloadmeta-python2-b884f843127ee127ca0329fe03aef52e31b9c07d.tar.gz
python-pysnmp: add new recipe
python-pysnmp is a pure-Python SNMPv1/v2c/v3 library, it's required by python-snimpy. (From meta-openembedded commit: 65525a2d74604a122cf149c206c843c478118219) Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pysnmp_4.3.5.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pysnmp_4.3.5.bb b/recipes-devtools/python/python-pysnmp_4.3.5.bb
new file mode 100644
index 0000000..0b38d58
--- /dev/null
+++ b/recipes-devtools/python/python-pysnmp_4.3.5.bb
@@ -0,0 +1,25 @@
+SUMMARY = "A pure-Python SNMPv1/v2c/v3 library"
+DESCRIPTION = "SNMP v1/v2c/v3 engine and apps written in pure-Python. \
+ Supports Manager/Agent/Proxy roles, scriptable MIBs, asynchronous \
+ operation (asyncio, twisted, asyncore) and multiple transports.\
+"
+HOMEPAGE = "https://pypi.python.org/pypi/pysnmp"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=280606d9c18f200e03e0c247ac61475a"
+
+SRCNAME = "pysnmp"
+
+SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "387aaa23c168ccc0b59775cfdf519fc0"
+SRC_URI[sha256sum] = "38253fe95cea33f352fb36e85f3c2874043401724300c4888df74835161169d2"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-pycrypto \
+ python-pyasn1 \
+ python-pysmi \
+"