aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-03-08 08:16:03 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-11 17:56:45 +0100
commit86ed8d19806900ec73e9fda1b4d4a6080e79d183 (patch)
treeb333f9b51d3b49ee583ae4eaf62cc0ff24eed0e5
parent3fec161f09425d8e77251cb21dac9c71f62c60c2 (diff)
downloadmeta-python2-86ed8d19806900ec73e9fda1b4d4a6080e79d183.tar.gz
python-serpent: add a python3 recipe
(From meta-openembedded commit: 5831b3680c4b57e229fc4dda71a0ee5b42ae8672) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-serpent.inc13
-rw-r--r--recipes-devtools/python/python-serpent_1.18.1.bb15
2 files changed, 15 insertions, 13 deletions
diff --git a/recipes-devtools/python/python-serpent.inc b/recipes-devtools/python/python-serpent.inc
new file mode 100644
index 0000000..a1520db
--- /dev/null
+++ b/recipes-devtools/python/python-serpent.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Serialization based on ast.literal_eval"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=2669deccb79531c74a5ddd71b45f5095"
+
+SRC_URI[md5sum] = "e2cd7b751274c59b420d4f54db9a49cf"
+SRC_URI[sha256sum] = "9afebb58ac8b827050e1969324388349dc9738b0a03b0d91567b328834a27732"
+
+inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ "
diff --git a/recipes-devtools/python/python-serpent_1.18.1.bb b/recipes-devtools/python/python-serpent_1.18.1.bb
index f18343a..0db3cf9 100644
--- a/recipes-devtools/python/python-serpent_1.18.1.bb
+++ b/recipes-devtools/python/python-serpent_1.18.1.bb
@@ -1,13 +1,2 @@
-SUMMARY = "Serialization based on ast.literal_eval"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://PKG-INFO;md5=2669deccb79531c74a5ddd71b45f5095"
-
-SRC_URI[md5sum] = "e2cd7b751274c59b420d4f54db9a49cf"
-SRC_URI[sha256sum] = "9afebb58ac8b827050e1969324388349dc9738b0a03b0d91567b328834a27732"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-netclient \
- ${PYTHON_PN}-numbers \
- "
+inherit setuptools
+require python-serpent.inc