aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-03-09 08:33:08 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-11 17:57:05 +0100
commit64bd3075e7e036f5df8a94dd97136a968fa3b6c6 (patch)
treeb88e1a4b900ae4576f3fd4bdec9bc2455dab9265
parent3249d12ae60ea1ecab521d05628e4eb40f1178a8 (diff)
downloadmeta-python2-64bd3075e7e036f5df8a94dd97136a968fa3b6c6.tar.gz
python-pyparsing: update to version 2.2.0
Fix the RDEPENDS and add a python3 version as well (From meta-openembedded commit: 1a373a033f482981eb59ff8d9eb7a9437fa18cd4) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pyparsing.inc19
-rw-r--r--recipes-devtools/python/python-pyparsing_2.1.10.bb9
-rw-r--r--recipes-devtools/python/python-pyparsing_2.2.0.bb2
3 files changed, 21 insertions, 9 deletions
diff --git a/recipes-devtools/python/python-pyparsing.inc b/recipes-devtools/python/python-pyparsing.inc
new file mode 100644
index 0000000..033e0db
--- /dev/null
+++ b/recipes-devtools/python/python-pyparsing.inc
@@ -0,0 +1,19 @@
+SUMMARY = "Python parsing module"
+HOMEPAGE = "http://pyparsing.wikispaces.com/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fb46329938e6bc829b256e37d5c1e31a"
+
+SRC_URI[md5sum] = "0214e42d63af850256962b6744c948d9"
+SRC_URI[sha256sum] = "0832bcf47acd283788593e7a0f542407bd9550a55a8a8435214a1960e04bcb04"
+
+inherit pypi
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
+"
diff --git a/recipes-devtools/python/python-pyparsing_2.1.10.bb b/recipes-devtools/python/python-pyparsing_2.1.10.bb
deleted file mode 100644
index 06f9845..0000000
--- a/recipes-devtools/python/python-pyparsing_2.1.10.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-SUMMARY = "Python parsing module"
-HOMEPAGE = "http://pyparsing.wikispaces.com/"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=fb46329938e6bc829b256e37d5c1e31a"
-
-SRC_URI[md5sum] = "065908b92904e0d3634eb156f44cc80e"
-SRC_URI[sha256sum] = "811c3e7b0031021137fc83e051795025fcb98674d07eb8fe922ba4de53d39188"
-
-inherit pypi setuptools
diff --git a/recipes-devtools/python/python-pyparsing_2.2.0.bb b/recipes-devtools/python/python-pyparsing_2.2.0.bb
new file mode 100644
index 0000000..90217f3
--- /dev/null
+++ b/recipes-devtools/python/python-pyparsing_2.2.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pyparsing.inc