aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-03-02 11:24:24 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-04 12:38:56 +0100
commit46493555aeb75d0fd2a8b3be09a2a0e0488e77f7 (patch)
treec19778e6303fa776134b9dbf3ff9db2e9161ed1a
parenta7c2d49211946465bffb468dc35347d19ef08791 (diff)
downloadmeta-python2-46493555aeb75d0fd2a8b3be09a2a0e0488e77f7.tar.gz
python-simplejson: relocate to meta-python and add a python3 version
(From meta-openembedded commit: 32b0092f6f6bb6687633e24ab44cf0f2ab73c810) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-simplejson.inc17
-rw-r--r--recipes-devtools/python/python-simplejson_3.10.0.bb2
2 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-simplejson.inc b/recipes-devtools/python/python-simplejson.inc
new file mode 100644
index 0000000..2eed199
--- /dev/null
+++ b/recipes-devtools/python/python-simplejson.inc
@@ -0,0 +1,17 @@
+SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e"
+
+SRC_URI[md5sum] = "426a9631d22851a7a970b1a677368b15"
+SRC_URI[sha256sum] = "953be622e88323c6f43fad61ffd05bebe73b9fd9863a46d68b052d2aa7d71ce2"
+
+inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-re \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+"
diff --git a/recipes-devtools/python/python-simplejson_3.10.0.bb b/recipes-devtools/python/python-simplejson_3.10.0.bb
new file mode 100644
index 0000000..e33edfe
--- /dev/null
+++ b/recipes-devtools/python/python-simplejson_3.10.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-simplejson.inc