aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-03-02 11:30:41 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-04 12:38:56 +0100
commit45a50c03e6315da37d8b23596499094473d63d70 (patch)
treeaddb9236f5aa65ff2009956f2531e75cffcb830c
parent46493555aeb75d0fd2a8b3be09a2a0e0488e77f7 (diff)
downloadmeta-python2-45a50c03e6315da37d8b23596499094473d63d70.tar.gz
python-anyjson: add a recipe for version 0.3.3
(From meta-openembedded commit: dcff4339d9deda0b1f70cd882587fec8a887aa91) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-anyjson.inc13
-rw-r--r--recipes-devtools/python/python-anyjson_0.3.3.bb2
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-anyjson.inc b/recipes-devtools/python/python-anyjson.inc
new file mode 100644
index 0000000..a0d20ff
--- /dev/null
+++ b/recipes-devtools/python/python-anyjson.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Wraps the best available JSON implementation available in a common interface"
+DESCRIPTION = "Anyjson loads whichever is the fastest JSON module installed and \
+provides a uniform API regardless of which JSON implementation is used."
+HOMEPAGE = "https://bitbucket.org/runeh/anyjson"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=989aa97e73c912a83a3c873fa11deb08"
+
+inherit pypi
+
+SRC_URI[md5sum] = "2ea28d6ec311aeeebaf993cb3008b27c"
+SRC_URI[sha256sum] = "37812d863c9ad3e35c0734c42e0bf0320ce8c3bed82cd20ad54cb34d158157ba"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-simplejson"
diff --git a/recipes-devtools/python/python-anyjson_0.3.3.bb b/recipes-devtools/python/python-anyjson_0.3.3.bb
new file mode 100644
index 0000000..31b8749
--- /dev/null
+++ b/recipes-devtools/python/python-anyjson_0.3.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-anyjson.inc