aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-04-21 17:08:14 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-26 20:13:28 +0200
commit3ec4bd52ad7bcd70475d8251fbefc264bee69471 (patch)
tree8f8f81e84d3d160d5cbf13092f3514b339e3868b
parentcfd79c8e1af42dbefadc8c08d7b192df1caba1e8 (diff)
downloadmeta-python2-3ec4bd52ad7bcd70475d8251fbefc264bee69471.tar.gz
python-ply: add new recipe
python-ply: PLY is yet another implementation of lex and yacc for Python. It's required by python-pysmi. (From meta-openembedded commit: 4ebcca667038218191cd28156f9236ea4a63ad1f) Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-ply_3.10.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-ply_3.10.bb b/recipes-devtools/python/python-ply_3.10.bb
new file mode 100644
index 0000000..8e61efa
--- /dev/null
+++ b/recipes-devtools/python/python-ply_3.10.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Python Lex and Yacc"
+DESCRIPTION = "Python ply: PLY is yet another implementation of lex and yacc for Python"
+HOMEPAGE = "https://pypi.python.org/pypi/ply"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://README.md;beginline=3;endline=30;md5=fcb04bc2f765e46ab7084d6ab6e452bb"
+
+SRCNAME = "ply"
+
+SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "1d63c166ab250bab87d8dcc42dcca70e"
+SRC_URI[sha256sum] = "96e94af7dd7031d8d6dd6e2a8e0de593b511c211a86e28a9c9621c275ac8bacb"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools