aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-03-02 20:29:20 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-07 13:29:45 +0100
commit17657953e6a259903d1223083fa3412db4514dc1 (patch)
treefd486c6d5a8e74c655d201071250b8de195eb85f
parent45a50c03e6315da37d8b23596499094473d63d70 (diff)
downloadmeta-python2-17657953e6a259903d1223083fa3412db4514dc1.tar.gz
python-babel: add initial recipe for version 2.3.4
(From meta-openembedded commit: d911e0f5f15b21fb50a50cfc7ba4873321d7c957) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-babel.inc20
-rw-r--r--recipes-devtools/python/python-babel_2.3.4.bb2
2 files changed, 22 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-babel.inc b/recipes-devtools/python/python-babel.inc
new file mode 100644
index 0000000..866ce78
--- /dev/null
+++ b/recipes-devtools/python/python-babel.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "A collection of tools for internationalizing Python applications"
+HOMEPAGE = "http://babel.edgewall.org/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e6eeaabc92cfc2d03f53e789324d7292"
+
+SRC_URI[md5sum] = "afa20bc55b0e991833030129ad498f35"
+SRC_URI[sha256sum] = "c535c4403802f6eb38173cd4863e419e2274921a01a8aad8a5b497c131c62875"
+
+PYPI_PACKAGE = "Babel"
+
+inherit pypi
+
+CLEANBROKEN = "1"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-pytz \
+ ${PYTHON_PN}-threading \
+"
diff --git a/recipes-devtools/python/python-babel_2.3.4.bb b/recipes-devtools/python/python-babel_2.3.4.bb
new file mode 100644
index 0000000..e0eadcd
--- /dev/null
+++ b/recipes-devtools/python/python-babel_2.3.4.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-babel.inc