aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2016-11-02 15:26:58 +0800
committerArmin Kuster <akuster808@gmail.com>2016-11-29 08:22:21 -0800
commit12ed8e51d9409cc480bc8b73a404cd791e1f759b (patch)
tree2a3e991b18724b19adbf4e26fc982f1948f8e58c
parent76e0400dc71aff7bbaea374bad7c47c93c931cb9 (diff)
downloadmeta-python2-12ed8e51d9409cc480bc8b73a404cd791e1f759b.tar.gz
python-m2crypto: inherit siteinfo
In recipe of python-m2crypto, it uses var SITEINFO_BITS which is from siteinfo.bbclass. Inherit siteinfo.bbclass to avoid compile error: | .../tmp/sysroots/qemumips64/usr/include/openssl/opensslconf.h:47: | Error: CPP #error ""Unknown __WORDSIZE detected"". | Use the -cpperraswarn option to continue swig processing. | error: command 'swig' failed with exit status 1 (From meta-openembedded commit: 9869a2d7890eb1bbf9408e9a0b18fdd63e3160c8) Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 007434d483b7c78380aa7becd017103493742ace) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-m2crypto_0.23.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-m2crypto_0.23.0.bb b/recipes-devtools/python/python-m2crypto_0.23.0.bb
index 73d8bb1..ab665d4 100644
--- a/recipes-devtools/python/python-m2crypto_0.23.0.bb
+++ b/recipes-devtools/python/python-m2crypto_0.23.0.bb
@@ -10,7 +10,7 @@ SRC_URI[sha256sum] = "1ac3b6eafa5ff7e2a0796675316d7569b28aada45a7ab74042ad089d15
SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch "
PYPI_PACKAGE = "M2Crypto"
-inherit pypi setuptools
+inherit pypi setuptools siteinfo
DEPENDS += "openssl swig-native"