aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-10-26 16:18:39 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-10-26 16:43:35 +0200
commita8c31720a45541b8b08c77ce8f4d3f6aa75c6f05 (patch)
tree63052c4740377f61e0889870617890bcc42d89fc
parent4ab3b5a6b141fa2c43ef71253430600be08bed55 (diff)
downloadmeta-python2-a8c31720a45541b8b08c77ce8f4d3f6aa75c6f05.tar.gz
python-pyparted: inherit pkgconfig
* otherwise fails when searching for libparted: http://errors.yoctoproject.org/Errors/Details/614897/ DEBUG: Executing shell function do_configure Traceback (most recent call last): File "setup.py", line 60, in <module> check_mod_version('libparted', need_libparted_version) File "setup.py", line 54, in check_mod_version modversion = subprocess.check_output(["pkg-config", "--modversion", module]).decode('utf-8').split()[0] File "TOPDIR/tmp-glibc/work/core2-64-oe-linux/python-pyparted/3.11.4+gitAUTOINC+104ca13567-r0/recipe-sysroot-native/usr/lib/python2.7/subprocess.py", line 216, in check_output process = Popen(stdout=PIPE, *popenargs, **kwargs) File "TOPDIR/tmp-glibc/work/core2-64-oe-linux/python-pyparted/3.11.4+gitAUTOINC+104ca13567-r0/recipe-sysroot-native/usr/lib/python2.7/subprocess.py", line 394, in __init__ errread, errwrite) File "TOPDIR/tmp-glibc/work/core2-64-oe-linux/python-pyparted/3.11.4+gitAUTOINC+104ca13567-r0/recipe-sysroot-native/usr/lib/python2.7/subprocess.py", line 1047, in _execute_child raise child_exception OSError: [Errno 2] No such file or directory Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-extended/python-pyparted/python-pyparted_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-extended/python-pyparted/python-pyparted_git.bb b/recipes-extended/python-pyparted/python-pyparted_git.bb
index 76981be..b5d6ef4 100644
--- a/recipes-extended/python-pyparted/python-pyparted_git.bb
+++ b/recipes-extended/python-pyparted/python-pyparted_git.bb
@@ -27,7 +27,7 @@ RDEPENDS:${PN}:class-target += " \
"
RDEPENDS:${PN}:class-native = ""
-inherit distutils
+inherit distutils pkgconfig
RDEPENDS:${PN} += "python-stringold python-codecs python-math python-subprocess"
RDEPENDS:${PN}:class-native = ""