aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-09-20 18:11:11 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-09-20 18:11:12 +0200
commit5243d509aebff378c1ae9d3dff6a29cfdc0dee1f (patch)
tree62ca54e888efd50c2d3624695ae8e586d656e6ce
parentf522fa70f93a9339f3b9991082af69a09fde675a (diff)
downloadmeta-python2-5243d509aebff378c1ae9d3dff6a29cfdc0dee1f.tar.gz
python-lxml: inherit pkgconfighonister
* fixes: | Building without Cython. | ERROR: /bin/sh: 1: pkg-config: not found | | ** make sure the development packages of libxml2 and libxslt are installed ** | | Using build configuration of libxslt | running build | running build_py | running build_ext | building 'lxml.etree' extension | gcc -fno-strict-aliasing -isystem/OE/build/oe-core/tmp-glibc/work/x86_64-linux/python-lxml-native/4.4.2-r0/recipe-sysroot-native/usr/include -O2 -pipe -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -isystem/OE/build/oe-core/tmp-glibc/work/x86_64-linux/python-lxml-native/4.4.2-r0/recipe-sysroot-native/usr/include -O2 -pipe -isystem/OE/build/oe-core/tmp-glibc/work/x86_64-linux/python-lxml-native/4.4.2-r0/recipe-sysroot-native/usr/include -fPIC -DCYTHON_CLINE_IN_TRACEBACK=0 -Isrc -Isrc/lxml/includes -I/OE/build/oe-core/tmp-glibc/work/x86_64-linux/python-lxml-native/4.4.2-r0/recipe-sysroot-native/usr/include/python2.7 -c src/lxml/etree.c -o build/temp.linux-x86_64-2.7/src/lxml/etree.o -w | In file included from src/lxml/etree.c:692: | src/lxml/includes/etree_defs.h:14:10: fatal error: libxml/xmlversion.h: No such file or directory | 14 | #include "libxml/xmlversion.h" | | ^~~~~~~~~~~~~~~~~~~~~ | compilation terminated. | Compile failed: command 'gcc' failed with exit status 1 | cc -I/usr/include/libxml2 -c /tmp/xmlXPathInithJP6pr.c -o tmp/xmlXPathInithJP6pr.o | unable to execute 'cc': No such file or directory | ********************************************************************************* | Could not find function xmlCheckVersion in library libxml2. Is libxml2 installed? | ********************************************************************************* | error: command 'gcc' failed with exit status 1 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-devtools/python/python-lxml_4.4.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-lxml_4.4.2.bb b/recipes-devtools/python/python-lxml_4.4.2.bb
index 7cfedbc..88b5544 100644
--- a/recipes-devtools/python/python-lxml_4.4.2.bb
+++ b/recipes-devtools/python/python-lxml_4.4.2.bb
@@ -21,7 +21,7 @@ SRC_URI[sha256sum] = "eff69ddbf3ad86375c344339371168640951c302450c5d3e9936e98d64
DEPENDS += "libxml2 libxslt"
-inherit pypi setuptools
+inherit pypi setuptools pkgconfig
# add to the defaults which are set in the setuptools bbclass
#