aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-04-13 10:16:52 -0300
committerArmin Kuster <akuster808@gmail.com>2016-05-02 14:03:02 -0700
commitaa42fa1e8cb2a3d7149b5fe75c947cf9e6e65670 (patch)
treee0b450116885b70db8e6bbcc064b45dc63d66005
parentb79269025d1b9b5c17556553e0f3b25efa2ac8bd (diff)
downloadmeta-python2-aa42fa1e8cb2a3d7149b5fe75c947cf9e6e65670.tar.gz
python-bcrypt: Add recipe for version 2.0.0
It's a modern password hashing for your software and your servers. (From meta-openembedded commit: fc3b141cbcd3f91fbb3b6fbfc643deb0cdadcbf1) Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-bcrypt_2.0.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-bcrypt_2.0.0.bb b/recipes-devtools/python/python-bcrypt_2.0.0.bb
new file mode 100644
index 0000000..3cbe33e
--- /dev/null
+++ b/recipes-devtools/python/python-bcrypt_2.0.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Modern password hashing for your software and your servers."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e19d0fe40c5ce4109e6bcbf4aab2a5bd"
+
+DEPENDS = "python-cffi-native"
+
+SRC_URI[md5sum] = "e7fb17be46904cdb2ae6a062859ee58c"
+SRC_URI[sha256sum] = "8b2d197ef220d10eb74625dde7af3b10daa973ae9a1eadd6366f763fad4387fa"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "\
+ python-cffi \
+ python-six \
+"