aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-03-07 18:00:14 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:37 +0100
commit9212c0364f869dffd23b7a40582804e9cecf425a (patch)
tree7c12250533967533d9ff774fea8440a17eafeab0
parent2db03dae15f7fe7d3f66927797c4646c77b4ca83 (diff)
downloadmeta-python2-9212c0364f869dffd23b7a40582804e9cecf425a.tar.gz
python-m2crypto: fix build issue
restore swig file fiddling: tmp/sysroots/qemux86/usr/include/openssl/opensslconf.h:45: Error: Unable to find 'openssl/opensslconf-64.h' error: command 'swig' failed with exit status 1 (From meta-openembedded commit: 830607415dd63ca5244ab8e51f402e046b03ca85) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-m2crypto_0.23.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-m2crypto_0.23.0.bb b/recipes-devtools/python/python-m2crypto_0.23.0.bb
index af8ca09..f6f0e1f 100644
--- a/recipes-devtools/python/python-m2crypto_0.23.0.bb
+++ b/recipes-devtools/python/python-m2crypto_0.23.0.bb
@@ -27,4 +27,26 @@ SWIG_FEATURES_x86-64 = "-D__x86_64__"
SWIG_FEATURES ?= ""
export SWIG_FEATURES
+# Get around a problem with swig, but only if the
+# multilib header file exists.
+#
+do_compile_prepend() {
+ if [ "${SITEINFO_BITS}" = "64" ];then
+ bit="64"
+ else
+ bit="32"
+ fi
+
+ if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then
+ for i in SWIG/_ec.i SWIG/_evp.i; do
+ sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i"
+ done
+ elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then
+ for i in SWIG/_ec.i SWIG/_evp.i; do
+ sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i"
+ done
+ fi
+}
+
+
BBCLASSEXTEND = "native"