aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-04-13 10:16:58 -0300
committerArmin Kuster <akuster808@gmail.com>2016-05-02 14:03:02 -0700
commit25a924aa766b63172ba62e15ac60f54520f7ff16 (patch)
treedd25c10c3cb2392fede51fa7216cd7d86b4a6183
parent7ab2ead8f9da7b48c6506b35b0059f7561cd5377 (diff)
downloadmeta-python2-25a924aa766b63172ba62e15ac60f54520f7ff16.tar.gz
python-flask-wtf: Add recipe for version 0.12
It's a simple integration of Flask and WTForms. (From meta-openembedded commit: 3e88e5e3aab3a69d863cdb874d70ced4ec9363ca) Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch28
-rw-r--r--recipes-devtools/python/python-flask-wtf_0.12.bb17
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch b/recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch
new file mode 100644
index 0000000..678f706
--- /dev/null
+++ b/recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch
@@ -0,0 +1,28 @@
+Upstream-Status: Inappropriate [configuration]
+
+Subject: [PATCH] import simplejson as json
+
+At runtime python-Flask-WTF tries to import json, but the module is not
+available, import simplejson as json solve the issue.
+
+Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
+---
+ flask_wtf/recaptcha/validators.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/flask_wtf/recaptcha/validators.py b/flask_wtf/recaptcha/validators.py
+index bcff23d..4a244bb 100644
+--- a/flask_wtf/recaptcha/validators.py
++++ b/flask_wtf/recaptcha/validators.py
+@@ -8,7 +8,7 @@ from flask import request, current_app
+ from wtforms import ValidationError
+ from werkzeug import url_encode
+ from .._compat import to_bytes, to_unicode
+-import json
++import simplejson as json
+
+ RECAPTCHA_VERIFY_SERVER = 'https://www.google.com/recaptcha/api/siteverify'
+ RECAPTCHA_ERROR_CODES = {
+--
+2.1.4
+
diff --git a/recipes-devtools/python/python-flask-wtf_0.12.bb b/recipes-devtools/python/python-flask-wtf_0.12.bb
new file mode 100644
index 0000000..79afaf6
--- /dev/null
+++ b/recipes-devtools/python/python-flask-wtf_0.12.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Simple integration of Flask and WTForms."
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=507e8635f25a06dc4f041a3a1b3359b3"
+
+SRC_URI[md5sum] = "c53a74e8ba481bf53405fd5efdf0339e"
+SRC_URI[sha256sum] = "bd99316c97ed1d1cb90b8f0c242c86420a891a6a2058f20717e424bf5b0bb80e"
+
+SRC_URI += " file://import-simplejson-as-json.patch"
+
+PYPI_PACKAGE = "Flask-WTF"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "\
+ python-wtforms \
+ python-simplejson \
+"