aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Looijmans <mike.looijmans@topic.nl>2015-09-06 16:42:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-08 16:21:39 +0200
commitf59a255ec9e75cde19408cfb79936455b37446ca (patch)
tree70270e2e0e4e248b176d8b06cfd102de5295ddf1
parent68303d15abcadaad01beecb4c19ffba185fd9346 (diff)
downloadmeta-python2-f59a255ec9e75cde19408cfb79936455b37446ca.tar.gz
python-pyopenssl: Inherit setuptools to fix failing install
Fixes the following error during install phase: ImportError: No module named setuptools_ext ERROR: python setup.py install execution failed. Reported-by: athoik@openpli.org (From meta-openembedded commit: e91df9ce327bd4115930e4b0403bd8e8fa1e0446) Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pyopenssl_0.15.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-pyopenssl_0.15.1.bb b/recipes-devtools/python/python-pyopenssl_0.15.1.bb
index 694da27..7f93012 100644
--- a/recipes-devtools/python/python-pyopenssl_0.15.1.bb
+++ b/recipes-devtools/python/python-pyopenssl_0.15.1.bb
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "f0a26070d6db0881de8bcc7846934b7c3c930d8f9c79d45883ee48984b
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit distutils
+inherit setuptools
PACKAGES =+ "${PN}-tests"
FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"