aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2015-08-24 17:27:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:17:07 +0200
commitbd7eb3a7d6a1496723f48bb525e23496cfa1bd8d (patch)
tree7aecbfc0004936f7bdbcef9471455c61498e3b08
parent81952a1fee57fbdc4f17ee289ea6af8e82d19f59 (diff)
downloadmeta-python2-bd7eb3a7d6a1496723f48bb525e23496cfa1bd8d.tar.gz
python3-decorator: Add new recipe
Use a common .inc file for the python-decorator and python3-decorator recipes. (From meta-openembedded commit: 4058807b84c52438b6dbda967875ab1a74b35655) Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-decorator.inc20
-rw-r--r--recipes-devtools/python/python-decorator_4.0.2.bb22
2 files changed, 21 insertions, 21 deletions
diff --git a/recipes-devtools/python/python-decorator.inc b/recipes-devtools/python/python-decorator.inc
new file mode 100644
index 0000000..2c230ff
--- /dev/null
+++ b/recipes-devtools/python/python-decorator.inc
@@ -0,0 +1,20 @@
+SUMMARY = "Python decorator utilities"
+HOMEPAGE = "http://pypi.python.org/pypi/decorator/"
+DESCRIPTION = "\
+The aim of the decorator module it to simplify the usage of decorators \
+for the average programmer, and to popularize decorators by showing \
+various non-trivial examples. Of course, as all techniques, decorators \
+can be abused and you should not try to solve every problem with a \
+decorator, just because you can."
+
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=41e24e0e235a97e60cdb5c4137fa2cd0"
+
+SRCNAME = "decorator"
+
+SRC_URI = "https://pypi.python.org/packages/source/d/decorator/decorator-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI[md5sum] = "033c9563af492c4ce2680ee6ca481fa7"
+SRC_URI[sha256sum] = "1a089279d5de2471c47624d4463f2e5b3fc6a2cf65045c39bf714fc461a25206"
diff --git a/recipes-devtools/python/python-decorator_4.0.2.bb b/recipes-devtools/python/python-decorator_4.0.2.bb
index bda0d71..f262168 100644
--- a/recipes-devtools/python/python-decorator_4.0.2.bb
+++ b/recipes-devtools/python/python-decorator_4.0.2.bb
@@ -1,22 +1,2 @@
-SUMMARY = "Python decorator utilities"
-HOMEPAGE = "http://pypi.python.org/pypi/decorator/"
-DESCRIPTION = "\
-The aim of the decorator module it to simplify the usage of decorators \
-for the average programmer, and to popularize decorators by showing \
-various non-trivial examples. Of course, as all techniques, decorators \
-can be abused and you should not try to solve every problem with a \
-decorator, just because you can."
-
-SECTION = "devel/python"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=41e24e0e235a97e60cdb5c4137fa2cd0"
-
-SRCNAME = "decorator"
-
-SRC_URI = "https://pypi.python.org/packages/source/d/decorator/decorator-${PV}.tar.gz"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
inherit setuptools
-
-SRC_URI[md5sum] = "033c9563af492c4ce2680ee6ca481fa7"
-SRC_URI[sha256sum] = "1a089279d5de2471c47624d4463f2e5b3fc6a2cf65045c39bf714fc461a25206"
+require python-decorator.inc