aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-11-03 04:02:24 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-06 17:49:42 +0100
commitaa8f143d73e81080ceda49f3b4cd097ade5c35cd (patch)
tree23d26284d2fa25158f6f196f816411bc8ead5c6d
parent3743358e84f3a8c860cdf6adbdc77a89f15ebd82 (diff)
downloadmeta-python2-aa8f143d73e81080ceda49f3b4cd097ade5c35cd.tar.gz
python-pygpgme: add python-pygpgme 0.3
PyGPGME is a Python module that lets you sign, verify, encrypt and decrypt messages using the OpenPGP format. (From meta-openembedded commit: 9a233d0b7869f00f3c7ec412e172e3d1f72a499a) Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pygpgme_0.3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pygpgme_0.3.bb b/recipes-devtools/python/python-pygpgme_0.3.bb
new file mode 100644
index 0000000..f06c344
--- /dev/null
+++ b/recipes-devtools/python/python-pygpgme_0.3.bb
@@ -0,0 +1,18 @@
+SUMMARY = "A Python module for working with OpenPGP messages"
+DESCRIPTION = "PyGPGME is a Python module that lets you sign, verify, \
+ encrypt and decrypt messages using the OpenPGP format."
+HOMEPAGE = "https://launchpad.net/pygpgme"
+SECTION = "devel/python"
+
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=6517bdc8f2416f27ab725d4702f7aac3"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/pygpgme/pygpgme-${PV}.tar.gz"
+SRC_URI[md5sum] = "d38355af73f0352cde3d410b25f34fd0"
+SRC_URI[sha256sum] = "5fd887c407015296a8fd3f4b867fe0fcca3179de97ccde90449853a3dfb802e1"
+
+S = "${WORKDIR}/pygpgme-${PV}"
+
+DEPENDS += "gpgme"
+
+inherit setuptools