aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-08-13 11:51:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:58:19 +0200
commit8f8ee8d6e14cef0076dd2e74609cdaaa08983f15 (patch)
treeef1d2e4b7e712909b16d9647b17efff3444561f9
parent8a924ab5ce83732f06f7a3349a83416a6b4a09ba (diff)
downloadmeta-python2-8f8ee8d6e14cef0076dd2e74609cdaaa08983f15.tar.gz
recipes: use class-native instead of deprecated virtclass-native.
virtclass overrides are deprecated, so use class overrides instead. (From meta-openembedded commit: c2cea10597ed1b843e00aa5ecedfd6005c7d7799) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-epydoc_3.0.1.bb2
-rw-r--r--recipes-devtools/python/python-lxml_3.4.4.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-epydoc_3.0.1.bb b/recipes-devtools/python/python-epydoc_3.0.1.bb
index 4ec0668..56880e5 100644
--- a/recipes-devtools/python/python-epydoc_3.0.1.bb
+++ b/recipes-devtools/python/python-epydoc_3.0.1.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=011c0d78eb6054d731c879132d7313f0"
HOMEPAGE = "http://epydoc.sourceforge.net/"
SRCNAME = "epydoc"
DEPENDS += "python"
-DEPENDS_virtclass-native += "python-native"
+DEPENDS_class-native += "python-native"
SRC_URI = "http://downloads.sourceforge.net/project/${SRCNAME}/${SRCNAME}/${PV}/${SRCNAME}-${PV}.tar.gz"
SRC_URI[md5sum] = "cdd6f6c76dd8bab5e653a343a0544294"
diff --git a/recipes-devtools/python/python-lxml_3.4.4.bb b/recipes-devtools/python/python-lxml_3.4.4.bb
index 2480e4d..4fab4f3 100644
--- a/recipes-devtools/python/python-lxml_3.4.4.bb
+++ b/recipes-devtools/python/python-lxml_3.4.4.bb
@@ -30,5 +30,5 @@ DISTUTILS_INSTALL_ARGS += " \
BBCLASSEXTEND = "native nativesdk"
RDEPENDS_${PN} += "libxml2 libxslt python-compression"
-RDEPENDS_${PN}_virtclass-native = "libxml2-native libxslt-native"
+RDEPENDS_${PN}_class-native = "libxml2-native libxslt-native"