aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2015-08-31 16:08:24 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-08 16:25:21 +0200
commit839d5214d690f21381513145be1cdda58b291ea1 (patch)
tree61123a0291edb0af86e2e190b1020bc3ee4486cc
parentf59a255ec9e75cde19408cfb79936455b37446ca (diff)
downloadmeta-python2-839d5214d690f21381513145be1cdda58b291ea1.tar.gz
python-pyroute2: Add recipe
(From meta-openembedded commit: 2315f412f625a85e683cf294356b651dcd05a029) Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch26
-rw-r--r--recipes-devtools/python/python-pyroute2_0.3.12.bb14
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch b/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch
new file mode 100644
index 0000000..d73da07
--- /dev/null
+++ b/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch
@@ -0,0 +1,26 @@
+Upstream-Status: Inappropriate [wrong dependency]
+
+Subject: [PATCH] import simplejson as json
+
+At runtime python-pyroute2 tries to import json, but the module is not
+available, import simplejson as json solve the issue.
+
+Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
+---
+ pyroute2/netlink/rtnl/ifinfmsg.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyroute2/netlink/rtnl/ifinfmsg.py b/pyroute2/netlink/rtnl/ifinfmsg.py
+index 4f14f25..55643eb 100644
+--- a/pyroute2/netlink/rtnl/ifinfmsg.py
++++ b/pyroute2/netlink/rtnl/ifinfmsg.py
+@@ -1,5 +1,5 @@
+ import os
+-import json
++import simplejson as json
+ import errno
+ import select
+ import struct
+--
+2.1.4
+
diff --git a/recipes-devtools/python/python-pyroute2_0.3.12.bb b/recipes-devtools/python/python-pyroute2_0.3.12.bb
new file mode 100644
index 0000000..d809d97
--- /dev/null
+++ b/recipes-devtools/python/python-pyroute2_0.3.12.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "A pure Python netlink and Linux network configuration library"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=270323035ef766597dabd91747c36e3d"
+
+SRC_URI[md5sum] = "5d83ec82acb54ab88c98f0d25d13308b"
+SRC_URI[sha256sum] = "c0e1637a75e099104f14d9e03fd5a698dfcc923a22fbfac4a19bd7e94d1fcaa5"
+
+SRC_URI += "file://import-simplejson-as-json.patch"
+
+inherit pypi
+
+RDEPENDS_${PN} = "python-distutils \
+ python-simplejson \
+ "