aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McGregor <dan.mcgregor@usask.ca>2015-11-04 23:05:54 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-06 17:53:57 +0100
commit756f4f56d61ed06446f7db887e5c3ea7467a5c07 (patch)
tree92c635696b506ac912ba4f578e7a030c23d8d227
parentaa8f143d73e81080ceda49f3b4cd097ade5c35cd (diff)
downloadmeta-python2-756f4f56d61ed06446f7db887e5c3ea7467a5c07.tar.gz
python-html5lib: import recipe from meta-openstack
This recipe is needed for GateOne. (From meta-openembedded commit: 0b895ac766b3e5843a38cc7838368eed53386ab3) Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-html5lib_0.999.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-html5lib_0.999.bb b/recipes-devtools/python/python-html5lib_0.999.bb
new file mode 100644
index 0000000..34a8b30
--- /dev/null
+++ b/recipes-devtools/python/python-html5lib_0.999.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "HTML parser based on the WHATWG HTML specifcation"
+HOMEPAGE = "https://github.com/html5lib/html5lib-python"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ba5ada9e6fead1fdc32f43c9f10ba7c"
+
+SRCNAME = "html5lib"
+SRC_URI = "http://pypi.python.org/packages/source/h/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "acb8ba4d6db5637360a07859192eb7f8"
+SRC_URI[sha256sum] = "c3887f7e2875d7666107fa8bee761ff95b9391acdcc7cd1b5fd57a23b5fbc49e"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools