aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Borzecki <maciej.borzecki@open-rnd.pl>2015-07-13 14:44:11 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-30 21:03:26 +0200
commit712eaf285f8e4ad7637eb767fe188fd99a7097c0 (patch)
tree7e4b9fef6589bf2800707a275bec06e0b1645750
parente60f42224d825d43bd91f339319bccbd03e425cc (diff)
downloadmeta-python2-712eaf285f8e4ad7637eb767fe188fd99a7097c0.tar.gz
python-sparts: add recipe
Adding recipe for python-sparts, a library for rapid service prototyping. Change-Id: I9de406dc40267e008f5a67f0d4d91ed47a707262 (From meta-openembedded commit: 4eb06c68fbbc9ba9dd9925ad807a1cc087d58974) Signed-off-by: Maciej Borzecki <maciej.borzecki@open-rnd.pl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-sparts_0.7.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-sparts_0.7.2.bb b/recipes-devtools/python/python-sparts_0.7.2.bb
new file mode 100644
index 0000000..e9a9e64
--- /dev/null
+++ b/recipes-devtools/python/python-sparts_0.7.2.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Library for rapid service prototyping with minimal boilerplate"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0c1554636a564da3baf037ac652fc831"
+SRCNAME = "sparts"
+
+SRC_URI = "git://github.com/facebook/sparts.git"
+SRCREV = "128cf9c2f82b00cb2d8648033970870c73641f02"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "\
+ python-subprocess \
+ python-six \
+ python-argparse \
+ python-re \
+ python-shell \
+ python-threading \
+ python-logging \
+ python-unixadmin \
+ python-distutils \
+ python-daemonize \
+ python-futures \
+"