aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2015-05-07 17:28:17 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-13 14:34:24 +0200
commit472c4e32726f8343854c31047092f1ac5783a0e6 (patch)
tree44d092467753171e51844a113b901a9dfb5f0b21
parent699aacce6304ed5714223f7fb3077d34dce6161a (diff)
downloadmeta-python2-472c4e32726f8343854c31047092f1ac5783a0e6.tar.gz
python-thrift: Add recipe.
Direct copy from recipe in meta-cloud-services. Same recipe is also in meta-openstack. GNU Radio (in meta-sdr) will needs this recipe so it seems like time to move the recipe to a central layer. (From meta-openembedded commit: a61450e764bc0e228f9284daa50f02d3abfa0b84) Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-connectivity/python-thrift/python-thrift_0.9.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-connectivity/python-thrift/python-thrift_0.9.2.bb b/recipes-connectivity/python-thrift/python-thrift_0.9.2.bb
new file mode 100644
index 0000000..ec2ea0c
--- /dev/null
+++ b/recipes-connectivity/python-thrift/python-thrift_0.9.2.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Python bindings for the Apache Thrift RPC system"
+HOMEPAGE = "https://pypi.python.org/pypi/amqp/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=df17a59cc9e1327ec49c2285e13ac477"
+
+SRCNAME = "thrift"
+
+SRC_URI = "https://pypi.python.org/packages/source/t/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "91f1c224c46a257bb428431943387dfd"
+SRC_URI[sha256sum] = "08f665e4b033c9d2d0b6174d869273104362c80e77ee4c01054a74141e378afa"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools