aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2015-08-24 17:27:53 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:17:07 +0200
commit073553a3a53aef11e1a96bed549c5544d2d988ef (patch)
treebf1883d7e48d08e5d76f60794bf4b3b22283155b
parent1564cfb9ab21e21e78e1ec6fea0f70597678c28f (diff)
downloadmeta-python2-073553a3a53aef11e1a96bed549c5544d2d988ef.tar.gz
python3-lxml: Add new recipe
Use a common .inc file for the python-lxml and python3-lxml recipes. (From meta-openembedded commit: b13250198de5e1a5461e3e8079cf858cc6a084a3) Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-lxml.inc31
-rw-r--r--recipes-devtools/python/python-lxml_3.4.4.bb34
2 files changed, 32 insertions, 33 deletions
diff --git a/recipes-devtools/python/python-lxml.inc b/recipes-devtools/python/python-lxml.inc
new file mode 100644
index 0000000..9d1bfbc
--- /dev/null
+++ b/recipes-devtools/python/python-lxml.inc
@@ -0,0 +1,31 @@
+SUMMARY = "Python XML bindings for libxml2 and libxslt"
+DESCRIPTION = "Powerful and Pythonic XML processing library combining \
+libxml2/libxslt with the ElementTree API."
+HOMEPAGE = "http://codespeak.net/lxml"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b"
+SRCNAME = "lxml"
+
+DEPENDS = "libxml2 libxslt"
+
+SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "a9a65972afc173ec7a39c585f4eea69c"
+SRC_URI[sha256sum] = "b3d362bac471172747cda3513238f115cbd6c5f8b8e6319bf6a97a7892724099"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+DISTUTILS_BUILD_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
+"
+
+DISTUTILS_INSTALL_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS_${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
+RDEPENDS_${PN}_class-native = "libxml2-native libxslt-native"
diff --git a/recipes-devtools/python/python-lxml_3.4.4.bb b/recipes-devtools/python/python-lxml_3.4.4.bb
index 4fab4f3..81ccb12 100644
--- a/recipes-devtools/python/python-lxml_3.4.4.bb
+++ b/recipes-devtools/python/python-lxml_3.4.4.bb
@@ -1,34 +1,2 @@
-SUMMARY = "Python XML bindings for libxml2 and libxslt"
-DESCRIPTION = "Powerful and Pythonic XML processing library combining \
-libxml2/libxslt with the ElementTree API."
-HOMEPAGE = "http://codespeak.net/lxml"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b"
-SRCNAME = "lxml"
-
-DEPENDS = "libxml2 libxslt"
-
-SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "a9a65972afc173ec7a39c585f4eea69c"
-SRC_URI[sha256sum] = "b3d362bac471172747cda3513238f115cbd6c5f8b8e6319bf6a97a7892724099"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
inherit setuptools
-
-DISTUTILS_BUILD_ARGS += " \
- --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
- --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
-"
-
-DISTUTILS_INSTALL_ARGS += " \
- --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
- --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
-"
-
-BBCLASSEXTEND = "native nativesdk"
-
-RDEPENDS_${PN} += "libxml2 libxslt python-compression"
-RDEPENDS_${PN}_class-native = "libxml2-native libxslt-native"
-
+require python-lxml.inc